I had a working version of Ubuntu on my hp stream 13, and in my own stupidity I tried to repair the windows installation from EFI file and a recovery disk. I stopped before it advanced a lot, but now I have a partition with all my data which I cannot use because it says "basic data partition" and content "unknown".

I hoped I can reboot the system in that HD partition but the grub repair answers I found did not work. Is there any way I can recover the data stored there? I tried already several programs which did nothing like reinstalling grub, testdisk, gdisk...

I learnt the lesson. Do not touch OS before saving important data.

I hope you can help. Thanks!

  • That wasn't stupidity bro,......you were just being passionately curious.We all are. – Dominic Motuka Jan 25 '16 at 11:36
  • This thread is on NTFS, but recovery is the same. First try testdisk to see if it sees correct partitions, deeper search in testdisk to see if it sees data and immediately backup if it does. If not then try photorec. askubuntu.com/questions/286181/… – oldfred Jan 28 '16 at 15:38
  • Testdisk did not find any data, and Photorec found many things, but most of them did not make any sense. I just wanted to recover the data stored in my /home folder. I guess that Photorec searched in all the disk and the files I get come from all the programs installed, and so, which are not useful for me. Is there any other program to recover data, or these two are the best solution? – David Vazquez Feb 1 '16 at 17:01

Manually mount the filesystem in read only mode.

Check to see if you have a mount point (folder for mounting your partition in) for your Windows partition in the folder /media using this command:

ls /media

If you don't see a folder for your Windows partition, you should create one with the following command:

sudo mkdir /media/windows

Next, mount the partition in read-only mode onto this folder with this command:

mount -t ntfs-3g -o ro /dev/sda3 /media/windows

Note that you should change /media/windows if your mountpoint is called something else. Now you will be able to view/open files on your Windows partition using any program in Ubuntu. However you will not be able to write to the partition or modify any files as it is in read only mode.That way you will recover your data

| improve this answer | |
  • I cannot mount it like that. The OS is intalled in eMMC card, therefore the path to the partition is /dev/mmcblk0p3, but when I type "df" it does not appear. I can see it when I do "ls /dev/", so it is there, but ubuntu does not recognize the filesystem type (i guess), so no option works when I try to mount it (you put ntfs, which does not work). It should be ext4, since I had ubuntu installed there, but as I overwrote something there I guess it is corrupted now. I still hope to find some magic solution, but I am afraid I will have to lose my data. Is there anything else you have in mind? – David Vazquez Jan 25 '16 at 14:19

Just to add more information to my input. I did not find any way to mount this partition. I am thinking on installing grub in this partition and hope it becomes bootable, but I did not want to write anything on the disk before I could get an answer about mounting it. Is there any way to "force" mount making the system to "believe" is a ext3/ext4 partition?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.