5

I was about 90% through downloading a torrent when I needed to do a reboot. When I turned the computer back on and went back into Transmission to resume downloading I got the message:

Error no data found! Ensure your drives are connected or use "set location"

I'm not sure why this happened as the drives were never physically disconnected, but maybe perhaps I launched Transmission before they were mounted. In an attempt to fix this, I restarted the computer and allowed the drives to mount before starting Transmission, but I still got the same error about the missing data.

In attempt to fix this, I tried the following:

Right clicking the torrent in Transmission, then clicking "Set Location", selecting 'data is already there' radio button, and then navigating to the folder where the data is. (I made sure I pointed Transmission to the parent directory where the data was downloading to. To double check where Transmission thought the data was, I right clicked the torrent in Transmssion, went to properties, and looked at LOCATION, which showed exactly where I told it to set the folder to.

After setting the location to where the files were I right clicked on the torrent and clicked 'Verify Local Data', but nothing seemed to happen after that and the error remained.

I also did the above actions with 'Move Data File To' the location, with no results either.

STILL NO LUCK.

So, the only thing I can think of at this opint is something I read on another site about the files. Someone mentioned that if I did not download ALL the files set out in the torrent file, that Transmission might think it's not the same when trying to reconnect. In my case when I was prompted to choose which files I wanted to download from the torrent, I did not choose everything (omitting to download some files).

Could this be the reason this is not working? Is there another way to make this work without having to re-download the whole thing (this is a 100 gig+ torrent, and I dont want to lose my ratio, and time spent getting the files).

Using Transmission v.2.82 (14160) on Ubuntu 14.04

Thank you

2 Answers 2

4

No promises, but the following worked for me:

  • Right-click the torrent, then select Copy Magnet Link to Clipboard
  • Right-click the torrent, then select Remove
  • Click Remove
  • File -> Open URL
  • Click Open
  • Click Open again
  • Right-click the newly (re)created torrent, then select Verify Local Data

Good luck.

1
  • it worked, even after moving files from original folder to a new one.
    – logoff
    Commented Aug 14, 2019 at 16:37
0

It works for me also!

I´ve downloaded the torrent file and added in Transmission linux path to that file rather than the .torrent (with "start when added" option uncheck).

Than:

  • click "Set Location" to point to your directory on computer;
  • click "Verify local data"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .