Possible Duplicate:
Every other time I reboot, I loose my applications lens in Unity!

It was working about an hour ago, now it doesn't give any results (even for "firefox" for example). What's wrong ?

  • Have you tried rebooting? – Greg Treleaven Oct 26 '11 at 19:47
  • Yes, I did. This problem occured when I added pidging to the startup manager. – Quentin Oct 26 '11 at 19:50
  • This may answer it: askubuntu.com/questions/34902/… – Greg Treleaven Oct 26 '11 at 19:55
  • Searching files works - but I still can't search through apps ("terminal", "firefox" or "evolution" don't give any results). – Quentin Oct 26 '11 at 20:33
  • If you press super+a (Windows logo key) this will open the Applications search, does your search give results there? – Greg Treleaven Oct 30 '11 at 16:36

I have the same problem. Selecting "Applications" just results in an empty box and no searches come up with any applications.

I finally found this solution: http://ubuntuforums.org/showthread.php?t=1853156

I ran the command that begins: "sudo apt-get install --reinstall..."

I got some errors that some packages did not exist, so I just removed them from the command line and tried the command again, until it worked.

"sudo lightdm restart" gave me an error...apparently root does not have permission to access a user's display manager? But no matter...the apt-get re-install did the trick and the next time I clicked on the dash home, the applications were all back.

| improve this answer | |
  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Imagine the linked site goes down for maintenance or forever - your answer would become worthless. – htorque Nov 1 '11 at 8:14
  • Also, the right command is sudo restart lightdm, or you can just log out and back in. – htorque Nov 1 '11 at 8:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.