9

Alienware 17 r3 laptop, internal speakers work fine, headphone jack(s) seem to be ignored, so I can't get sound to an external speaker. (The Alienware has a second "microphone" jack, which apparently can double as another headphone jack.) Also: I've got it dual-booted to Windows 10, and the headphones work fine under Windows.

I saw that another user had essentially the same problem Ubuntu 15.10 Headphones No Sound but it doesn't seem to have been resolved. My system shows only small variations from the original bug report, so it's surely the same issue.

inxi:

> inxi -Fxz
System:    Host: jakku Kernel: 4.2.0-25-generic x86_64 (64 bit gcc: 5.2.1)
           Desktop: Unity 7.3.2 (Gtk 3.16.7-0ubuntu3)
           Distro: Ubuntu 15.10 wily
Machine:   System: Alienware product: Alienware 17 R3 v: 1.2.3
           Mobo: Alienware model: Alienware 17 R3 v: A00
           Bios: Alienware v: 1.2.3 date: 11/11/2015
CPU:       Quad core Intel Core i7-6700HQ (-HT-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 20726
           clock speeds: max: 3500 MHz 1: 2600 MHz 2: 3294 MHz 3: 3355 MHz
           4: 3369 MHz 5: 3381 MHz 6: 2600 MHz 7: 3183 MHz 8: 3207 MHz
Graphics:  Card-1: Intel Device 191b bus-ID: 00:02.0
           Card-2: NVIDIA GM204M [GeForce GTX 980M] bus-ID: 01:00.0
           Display Server: X.Org 1.17.2 driver: nvidia
           Resolution: 3440x1440@59.97hz, 1920x1080@60.02hz
           GLX Renderer: GeForce GTX 980M/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 352.63 Direct Rendering: Yes
Audio:     Card Intel Sunrise Point-H HD Audio
           driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.2.0-25-generic
Network:   Card-1: Qualcomm Atheros Device e0a1
           driver: alx port: d000 bus-ID: 3b:00.0
           IF: enp59s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
           driver: ath10k_pci bus-ID: 3c:00.0
           IF: wlp60s0 state: down mac: <filter>
           Card-3: Atheros usb-ID: 001-004
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 1128.2GB (33.5% used)
           ID-1: /dev/sda model: SanDisk_X300_M.2 size: 128.0GB
           ID-2: /dev/sdb model: HGST_HTS721010A9 size: 1000.2GB
Partition: ID-1: / size: 33G used: 6.4G (21%) fs: ext4 dev: /dev/sda6
           ID-2: swap-1 size: 16.38GB used: 0.00GB (0%) fs: swap dev: /dev/sda7
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 57.0C mobo: N/A gpu: 0.0:57C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 244 Uptime: 1:34 Memory: 1293.5/15947.5MB
           Init: systemd runlevel: 5 Gcc sys: 5.2.1
           Client: Shell (tcsh 6.18.01) inxi: 2.2.16 

dmesg:

> dmesg | grep snd
[    2.350920] snd_hda_intel 0000:00:1f.3: enabling device (0000 -> 0002)
[    2.351041] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    2.376447] snd_hda_codec_ca0132 hdaudioC0D0: autoconfig for CA0132: line_outs=1 (0xb/0x0/0x0/0x0/0x0) type:speaker
[    2.376449] snd_hda_codec_ca0132 hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    2.376450] snd_hda_codec_ca0132 hdaudioC0D0:    hp_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    2.376451] snd_hda_codec_ca0132 hdaudioC0D0:    mono: mono_out=0x0
[    2.376452] snd_hda_codec_ca0132 hdaudioC0D0:    inputs:
[    2.376453] snd_hda_codec_ca0132 hdaudioC0D0:      Mic=0x12
[    2.376454] snd_hda_codec_ca0132 hdaudioC0D0:      Line=0x11

lspci:

> sudo lspci -v | grep -A7 -i "audio"
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
    Subsystem: Dell Device 0708
    Flags: bus master, fast devsel, latency 32, IRQ 136
    Memory at dd128000 (64-bit, non-prefetchable) [size=16K]
    Memory at dd100000 (64-bit, non-prefetchable) [size=64K]
    Capabilities: [50] Power Management version 3
    Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
    Kernel driver in use: snd_hda_intel

aplay:

> aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: CA0132 Analog [CA0132 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: CA0132 Digital [CA0132 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

pacmd:

> pacmd
Welcome to PulseAudio 6.0! Use "help" for usage information.
>>> list-sinks
1 sink(s) available.
  * index: 0
    name: <alsa_output.pci-0000_00_1f.3.analog-stereo>
    driver: <module-alsa-card.c>
    flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
    state: SUSPENDED
    suspend cause: IDLE 
    priority: 9959
    volume: front-left: 19986 /  30% / -30.95 dB,   front-right: 19986 /  30% / -30.95 dB
            balance 0.00
    base volume: 46396 /  71% / -9.00 dB
    volume steps: 65537
    muted: no
    current latency: 0.00 ms
    max request: 0 KiB
    max rewind: 0 KiB
    monitor source: 0
    sample spec: s16le 2ch 48000Hz
    channel map: front-left,front-right
                 Stereo
    used by: 0
    linked by: 0
    configured latency: 0.00 ms; range is 0.50 .. 341.33 ms
    card: 0 <alsa_card.pci-0000_00_1f.3>
    module: 6
    properties:
        alsa.resolution_bits = "16"
        device.api = "alsa"
        device.class = "sound"
        alsa.class = "generic"
        alsa.subclass = "generic-mix"
        alsa.name = "CA0132 Analog"
        alsa.id = "CA0132 Analog"
        alsa.subdevice = "0"
        alsa.subdevice_name = "subdevice #0"
        alsa.device = "0"
        alsa.card = "0"
        alsa.card_name = "HDA Intel PCH"
        alsa.long_card_name = "HDA Intel PCH at 0xdd128000 irq 136"
        alsa.driver_name = "snd_hda_intel"
        device.bus_path = "pci-0000:00:1f.3"
        sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
        device.bus = "pci"
        device.vendor.id = "8086"
        device.vendor.name = "Intel Corporation"
        device.product.id = "a170"
        device.product.name = "Sunrise Point-H HD Audio"
        device.form_factor = "internal"
        device.string = "front:0"
        device.buffering.buffer_size = "65536"
        device.buffering.fragment_size = "32768"
        device.access_mode = "mmap+timer"
        device.profile.name = "analog-stereo"
        device.profile.description = "Analog Stereo"
        device.description = "Built-in Audio Analog Stereo"
        alsa.mixer_name = "Intel Skylake HDMI"
        alsa.components = "HDA:11020011,10280708,00100918 HDA:80862809,80860101,00100000"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    ports:
        analog-output-lineout: Line Out (priority 9900, latency offset 0 usec, available: yes)
            properties:

    active port: <analog-output-lineout>

pulseaudio config files:

> cd /usr/share/pulseaudio/alsa-mixer/paths/
> ls
analog-input-aux.conf              analog-output-headphones-2.conf
analog-input-dock-mic.conf         analog-output-headphones.conf
analog-input-fm.conf               analog-output-lineout.conf
analog-input-front-mic.conf        analog-output-mono.conf
analog-input-headphone-mic.conf        analog-output-speaker-always.conf
analog-input-headset-mic.conf          analog-output-speaker.conf
analog-input-internal-mic-always.conf  analog-output.conf
analog-input-internal-mic.conf         analog-output.conf.common
analog-input-linein.conf           hdmi-output-0.conf
analog-input-mic-line.conf         hdmi-output-1.conf
analog-input-mic.conf              hdmi-output-2.conf
analog-input-mic.conf.common           hdmi-output-3.conf
analog-input-rear-mic.conf         hdmi-output-4.conf
analog-input-tvtuner.conf          hdmi-output-5.conf
analog-input-video.conf            hdmi-output-6.conf
analog-input.conf              hdmi-output-7.conf
analog-input.conf.common           iec958-stereo-output.conf

speaker-test: (plays fine out of built-in speakers, ignores headphones)

> speaker-test -t wav -Dplug:front

speaker-test 1.0.29

Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 1 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 64 to 16384
Period size range from 32 to 8192
Using max buffer size 16384
Periods = 4
was set period_size = 4096
was set buffer_size = 16384
 0 - Front Left
Time per period = 1.195038
 0 - Front Left
Time per period = 1.450744
 0 - Front Left

alsa-info.sh output can be found here: http://www.alsa-project.org/db/?f=464ac3c346a6be1214d385a2d44e74e587b2ba46

Everything works fine with internal, built-in speakers. But I can't get any sound out of the headphones. Anyone have any ideas? Thanks!

Edit

In case it helps anyone, Windows 10 lists the sound card as "Sound Blaster Recon3Di" (where the headphones work just fine).

  • Did you find a solution? – vikramreddym Dec 30 '16 at 6:14
  • No. It appears that Creative audio is not supported under Ubuntu linux. As far as I can tell, there is no workaround. (I eventually got a new laptop, and paid a lot more attention to the linux compatibility of each hardware component, before I selected my new model.) – Don Geddis Dec 31 '16 at 16:13
3

I found the solution somewhere. Do the following:

  • In terminal, enter the command "alsamixer".

  • An ASCI UI will open, use the arrow keys to find the item: "HP/speaker Auto Detect". it will say "Off" next to it.

  • Press M and the "Off" tag will disappear.

  • Re-plug your headphones.

  • Enjoy!

  • I started alsamixer, found the HP/Speaker Auto Detect option. Mine was already on, but I pressed M to toggle it off, then M again to toggle it back on. I replugged in my headphones. There was no effect at all. Sound continues to come out of the onboard speakers, and no sound comes out of the headphones. – Don Geddis Aug 4 '16 at 21:37
  • Setting HP/Speaker Auto Detect on and HP/Speaker to off did the trick for me – dimus May 5 '17 at 18:23
2

I had exactly the same issue. Apparently the Alienware 17 r3 is comparatively a new model coming out in late September last year so lots of driver issues exist.

FAQ:

Q.Wifi not working?

A.Follow this link to fix Broadcom ath10k(killer wifi) wireless card. https://github.com/kvalo/ath10k-firmware/pull/3 (Note: Your kernel should be higher than the ubuntu 15.10 official image's)

Q.Could not boot and drop to initramfs?

A.If it is the i915 Guc issue, no solution yet since i already tried to update the latest firmware from intel (kernel 4.3.3) but still 'firmware-4.bin'not found issue exists. If it is the ssd not found issue, try to add 'nvme' to: /etc/initramfs-tools/modules and run 'update-initramfs -a'(kernel 4.4.0)

Q.Could not mount!!!Ubuntu will freeze when back to unity login screen because of ssd detached from system i think. Very annoying issue since i have to move my laptop with lid open or choose 'do nothing' option in power setting.

A.No clue yet.

Q.Only internal speaker works?

A.No solution yet.I am now running ubuntu 16.04 daily build and 4.4 kernel but still no sound from my headphones. In about kernel 4.4 rc6 diff, See line 772: https://github.com/torvalds/linux/blob/master/sound/pci/hda/patch_ca0132.c It seems like this issue is marked not urgent or no quick solution yet since no driver source code is provided by Creative. Hopes anyone could contact Creative to help fix this issue.

Other issues:

-Unpredictable lights on/off each time booting into ubuntu, no working light switch control software yet.

-'BTRFS error could not find root 8' if you are using btrfs file system instead of ext4.

  • 1
    Wow. So it actually just doesn't work. Alienware happened to choose a Creative soundcard, and Creative doesn't care enough about linux to offer drivers ... so there really isn't a fix. That surprises me. But I very much appreciate you filling in the information! – Don Geddis Jan 28 '16 at 16:50
  • Also, fn + F11 does not turn off touchpad – adn Jul 16 '16 at 2:52
2

I recently got the Alienware 17 R3, and had the same problem, I solved by updating the alsa driver on this site:

Download the *.deb corresponding for your Ubuntu based system and, before installing the .deb package, make sure you run:

sudo apt-get install dkms

After that just reboot and enable auto discovery options with the alsamixer command to access your alsa driver from your CLI, and that works for me.

  • There are two packages for 16.04.1. Which one it is? oem-audio-hda-daily-dkms - 0.201702250731~ubuntu16.04.1 or oem-audio-hda-daily-lts-xenial-dkms - 0.201702250732~ubuntu16.04.1 – vikramreddym Feb 26 '17 at 4:06
2

I found a workaround:

I bought this USB Audio Adapter

It didn't work out of the box, even after fiddling with system settings. It was detected, but when I changed voice to default, I got still sound from laptop. I tried changing order of audio device loading (USB Device first), still no result.

It turned out all I needed to do was to open pavucontrol (install it if you don't have it) and set sound to USB Audio Device. It has to be done for all audio programs separately (firefox, spotify, audacity, etc.). After that, plugging in headphones or external speakers causes output to be switched automatically to them.

Here is a more detailed forum thread about it

  • "Manually change settings for each program" - this smells like Linux. – sixtytrees Mar 13 '18 at 13:03
1

Try to change output device to "Digital Output" and see if the headphones works .

In modern laptops Digital and Analog Output can share the headphone jack which makes the kernel to not success to deduce the output purpose from the pin codec information.

It is still a bug but at least you could use the headphones.

  • 1
    Changing to "Digital Output (S/PDIF)" results in no sound at all: neither the headphones, nor the internal speakers. – Don Geddis Jun 29 '16 at 16:37
1

This command line works for me:

amixer -c 0 sset "HP/Speaker Auto Detect" on

Add to /etc/rc.local to have it run on boot.

1

Karly's solution did the trick. I too have an aliens 17 R3 with ubuntu 16.04 4.4.0-59-generic kernal i have been waiting for a fix for too long. The ubuntu Audio development team has updated the pulse audio (thank god). i am going to elaborate Karly's solution step by step.

  1. wget https://code.launchpad.net/~ubuntu-audio-dev/+archive/ubuntu/alsa-daily/+files/oem-audio-hda-daily-dkms_0.201702030732~ubuntu16.04.1_all.deb
  2. sudo dpkg -i oem-audio-hda-daily-dkms_0.201702030732~ubuntu16.04.1_all.deb
  3. amixer -c 0 sset "HP/Speaker Auto Detect" on
  4. amixer -c 0 sset "HP/Speaker" on
  5. Re-plug headphones/jack
  6. Enjoy

for other versions of ubuntu you can navigate to Launch Pad and change the link in step 1 and name of file in step 2

  • 1
    I did not do the fourth step and the headphones still work. Is the 4th step really required? – vikramreddym Feb 26 '17 at 3:51
0

I have Alienware 17 R3 and the same issue.

When I choose other device in alsamixer then default, namely HDA Intel PCH, my 'HP/Speaker Auto Detect' is always off. I can turn it on by pressing M, but that doesn't help. The only reaction is that when pluging speakers/headphones to one of the jacks, sound in internal speakers goes off, but speakers/headphones are silent. On default setting nothing happens when using jacks.

Moreover, the setting doesn't stick so after next boot 'HP/Speaker Auto Detect' is again off.

So far I haven't found any good and universal fix for it, although some claim that above advice worked for them (in alienware 15, not sure witch R).

However I was able to find solution for bad default sound quality. In windows sound was MUCH better then in linux where music was like from a can, just horrible. In case someone wanted to fix that as well, here is the solution (read through the end of the topic):

https://forum.manjaro.org/t/solved-terrible-sound-in-linux-much-better-in-windows/8203/22

protected by Community Feb 25 '17 at 20:47

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.