1

I was wondering if anyone has had success getting a Canon imageClass LBP6030W to work with linux. I have tried using the printer manager to add the printer after I plug it in, but there doesn't seem to be a driver available either through the built in list of drivers for Ubuntu or online. Trying the generic and the LBP5975 drivers have gotten me a setup where when I send jobs to the printer nothing happens.

Suggestions?

  • Do you have ufw turned on? If so make sure the ports for the printer are open. – Organic Marble Jan 24 '16 at 20:30
  • UFW is currently inactive, so that doesn't seem to be the problem. Thanks for the suggestion though. – ohnoplus Jan 25 '16 at 4:15
4

You need to have CUPS installed... which is already installed (if i am not wrong) if not installed

sudo apt-get install cups

install the drivers for the respective printer from the vendors website (use ".deb" package for you arch ie. i386/amd64 (32/64 bit arch))

try in your browser

localhost:631

try this link for drivers

or you may also try this for more help with linux printing.

| improve this answer | |
  • Thanks for this. `localhost:631' does nothing. Interesting link for drivers. I played around wiht the "[Linux] UFRII LT Printer Driver Ver.1.20" file on that site. There are a bunch of .deb files that I can run, but they don't seem to make the drivers I need start appearing nor do there seem to be PPD files. The windows driver links seem to have .exe files so I'm not sure those are useful either. The third link has a lot of information though I'm not sure it applies to my situation. It seems to be for installing CUPS in the first place on Kali or some such? – ohnoplus Jan 25 '16 at 4:14
  • 1
    Ah, hah. I have it. First of all, localhost:631 in browser does basically the same thing as the GUI add printer thing in ubuntu. Probably would work fine. With the drivers, I had to install both files in the "Linux_UFRIILT_PrinterDriver_V120_uk_EN/64-bit_Driver/Debian" location. That is both "cndrvcups-common_3.30-1_amd64" and "cndrvcups-ufr2lt-uk_1.20-1_amd64.deb". Then when I went to add the printer, it found the driver right away at the searching for drivers phase. And then I just added the printer without problem. Thanks for the useful hints. – ohnoplus Jan 25 '16 at 4:36
  • you may make the quesion more genieric... this would help many people – juggernauthk108 Jan 25 '16 at 5:05
  • Hmm. I've never done something like that before. I presume I could generalize to setting up Canon printers in general. Would I edit this question or post a new one? – ohnoplus Jan 25 '16 at 6:30
2

Steps that worked best for OP:

1) Go to the link posted by juggernaut1996

2) Download and extract the file called "[Linux] UFRII LT Printer Driver Ver.1.20"

3) Right click it and install with ubuntu software center (or probably dpkg on command line or other package manager)

4) From dash "Printers>Add> select Canon LBP6030/6040/6018L>Forward

5) The printer manager then finds the drivers on its own and you can just click the forward button until the printer becomes available.

Essentially I am following these instructions, but using the drivers linked above.

Edit September 2018: Since my earlier post, the link above doesn't seem to work anymore. I've also upgraded to ubuntu 18.04. I found these instructions to be valuable driver for canon LBP6030

| improve this answer | |
  • so you are using the older driver and getting success? I have gotten this 130 version to work before, but I installed a few debs separately and manually. Then my system gets errors but it all works.... Looking for a proper solution that apt will take care of. – Bhikkhu Subhuti Nov 6 '16 at 3:21
  • Apparently the printer driver link no longer works. If anyone finds a new one, let me know. – ohnoplus Sep 10 '18 at 21:29
1

linux-UFRIILT-drv-v140-uken (aka [Linux] UFRII LT Printer Driver Ver.1.40) worked for me. I had been trying linux-UFRII-drv-v350-uken. I had to uninstall the previous "350" version. Then it showed up in the Canon utility and installed just fine.

| improve this answer | |
  • Thanks. Only this instruction worked on Ubuntu 18.04. – Amit Deo Jul 5 '18 at 6:31
  • I'm not sure what this means exactly. Where does this driver appear? – ohnoplus Sep 10 '18 at 21:32
0

I have a 6030W and could not get working on 16.10. Yes Canon updated drivers on 12/16/2016 but didn't solve problem with my printer. I needed to install dependencies using apt-get on command line and all works now. command line was key as GUI didn't let me know what dependencies I needed.

| improve this answer | |
  • What's the command you're using? – P.-H. Lin Jan 16 '17 at 3:43
0

Remove the printer (from list) and run this:

wget http://gdlp01.c-wss.com/gds/0/0100005950/04/Linux_UFRIILT_PrinterDriver_V130_uk_EN.tar.gz && tar xvf Linux_UFRIILT_PrinterDriver_V130_uk_EN.tar.gz && cd Linux_UFRIILT_PrinterDriver_V130_uk_EN/ && sudo sh install.sh
  • Then answer y twice
  • Add the printer again (to the list)
  • You're done.
| improve this answer | |
0

go to the link suggested by juggernaut1996

Download and extract the file called "[Linux] UFRII LT Printer Driver Ver.1.20"

once you get this unzipped, look for the shell script install.sh just run that enter the ip of the printer detected by ubuntu and you are good to go would have commented but no points. thanks all

| improve this answer | |
0

I am using Ubuntu 17.10 and finaly setup the LBP6030B succesfully.

Instructions:

1) Download CANON LBP6030 linux driver from offical Canon Website.

***2) Use "install.sh" file for installation. Do not use deb packages! If you use deb packages, printer was registered but not working.

For this, rigt click and open terminal in he folder of install .sh file and use this command

sudo ./install.sh

3) Register printer. For me, installing driver from command line, return an error. Don't panic and use GNOME or Ubuntu Printer Manager for registering printer.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.