4

I have Asus TransformerBook TP500LB. Very good laptop - i5 5200U, 8GB RAM, nV 940M, ...

But, when I run windows10, my battery life is somewhere about 6-7hours (very low brightness and no gaming as well). In task manager I can see, that CPU frequency is scaling - I guess from 0.8GHz to 2.4 or something like that. But most of the time it is from 0.8-1.5. I guess that is why it has so long battery life.

On Ubuntu 15.04, the CPU never gets below 2GHz (I thing 2.2 all the time) and battery life is 3-4hours.

I installed TLP, tried googling some info about change CPU frequency because I believe this is the biggest problem (CPU runs on very high frequency and consums very much battery) but I didn't find good solution and nothing gets changed.

Any ideas?

  • So when I use 32bit variant of app, it is "better" for CPU? Or I don't get it. 64bit CPU should natively support 64bit apps, right? So where is problem? Thanks, I'll try it. – kubrdom Jan 24 '16 at 10:23
  • 1
    See my post here: askubuntu.com/questions/556894/tlp-dont-change-cpu-frequency and set tlp "performance" but use the cpufreq-indicator to throttle your cpu to get longer battery life. The cpufreq-indicator is a desktop app that runs on your dash like network-manager. Click on the cpu icon and set the settings from there. You will also need to edit grub. All the instructions are in the post. – mchid Jan 24 '16 at 10:47
  • Ok, I get it. I tried set "powersave" in TLP and it looks it works, little bit. Not as good as in windows, but sometimes it shows values below 2GHz. But it is not so often. Next thing is this - the higher CPU freq=>the higher temperature=>the higher fan spin. And my fan is always spinning at 2700rpm. – kubrdom Jan 24 '16 at 10:51
  • I posted the TLP configuration as an answer and included more info for your fan and extra drivers to properly utilize both of your graphics processors. – mchid Jan 24 '16 at 12:09
  • After trying many different options I found this solution to be the best: askubuntu.com/questions/1078939/ubuntu-18-04-battery-life/… – Pierre Pretorius Apr 17 at 20:18
6

TLP needs to be configured. Run the following command to edit your /etc/default/tlp file:

sudo nano /etc/default/tlp

Now, locate the lines:

#CPU_SCALING_GOVERNOR_ON_AC=performance
#CPU_SCALING_GOVERNOR_ON_BAT=performance

Uncomment these lines (remove the #) and change performance to powersave like this:

CPU_SCALING_GOVERNOR_ON_AC=powersave
CPU_SCALING_GOVERNOR_ON_BAT=powersave

Press CTRL + o and then press ENTER to save the file. Press CTRL + x to exit nano.

Restart tlp to apply the changes:

sudo service tlp restart

You may want to consider disabling pstate. intel_pstate only allows "performance" and "powersave". Disabling pstate allows the "ondemand" option which scales down the frequency when not in use and clocks up when there is more demand. See here for more info. Using the options and configuration mentioned in that post on my i3 2.4Ghz, in combination with the "ondemand" indicator-cpufreq setting, my processor idles about 1.2Ghz instead of the typical 2.1Ghz it is when set to "performance". On "powersave" it idles at about 8Ghz.


For your fan.

After installing Ubuntu, you should run a few commands to properly detect your temperature sensors. Run the following commands:

sudo apt-get update
sudo apt-get install lm-sensors
sudo sensors-detect

Answer "yes" to all the options.


For you Nvidia processor, you can install the proprietary drivers.

First open the Ubuntu Software Center, click on Edit, select Software Sources, then select Additional Drivers and select the recommended nvidia proprietary driver that is marked tested.

For your intel graphics, run the following commands:

sudo apt-get update
sudo apt-get install i965-va-driver libdrm-intel1 libvdpau-va-gl1

Additionally, to view accurate realtime stats for your processor in the terminal, install i7z:

sudo apt-get install i7z

To run i7z:

sudo i7z

Press CTRL + C to stop.

Alternatively, to view both physical and logical frequencies, run this instead:

watch -n 0.5 cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_cur_freq

Again, press CTRL + C to stop.

  • You are my hero :) ... It solved my issues. I disabled pstates and now I think, it has better power management (with tlp and so on). – kubrdom Jan 25 '16 at 10:21
  • @kubrdom Awesome, I think there has been a bug report created for this issue recently. I didn't know because I've been running on this type of configuration for a while and haven't had any issues. – mchid Jan 25 '16 at 10:25
  • @kubrdom Also, if you ever upgrade to 15.10, you can install the opensource intel graphics drivers from 01.org. See here: 01.org/linuxgraphics/downloads/… – mchid Jan 25 '16 at 10:29
  • Yes, I've installed this driver since 15.04, now I have 15.10 version. But I installed it with fresh install of Ubuntu. So I can't say if it has any good properties – kubrdom Jan 25 '16 at 10:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.