0

image~~~

I installed Pycharm-community in a wrong way

sudo ./pycharm.sh

now I remove its entire program directory and ~/.Pycharm50 config directory.

The problem is a invalid icon still appears in the Dash search result

I already tried

ls ~/.local/share/applications | grep pycharm
sudo ls /usr/share/applications | grep pycharm

but I got nothing.

I also rebooted but it is still there.

4
  • try this sudo find / -type f -iname '*pycharm*' – Raphael Jan 24 '16 at 9:46
  • Delete that file – Raphael Jan 24 '16 at 9:50
  • Logout and log back in – Raphael Jan 24 '16 at 9:52
  • If solved, write the solution. ("answer your question to share your knowledge in Q&A format") – user441517 Jan 24 '16 at 11:43
0

another file ~/.local/share/applications/jna_jar.desktop also need to be deleted. It seems to be openjdk brought by first time running pycharm.

[Desktop Entry]
Encoding=UTF-8
Version=1.0
Type=Application
Name=Welcome to PyCharm Community Edition
Icon=jna_jar.png
Exec=/usr/lib/jvm/java-7-openjdk-amd64/bin/java -Xbootclasspath/a:./../lib/boot.jar -classpath ./../lib/bootstrap.jar:./../lib/extensions.jar:./../lib/util.jar:./../lib/jdom.jar:./../lib/log4j.jar:./../lib/trove4j.jar:./../lib/jna.jar -Xms128m -Xmx750m -XX:MaxPermSize=350m -XX:ReservedCodeCacheSize=240m -XX:+UseConcMarkSweepGC -XX:SoftRefLRUPolicyMSPerMB=50 -ea -Dsun.io.useCanonCaches=false -Djava.net.preferIPv4Stack=true -XX:+HeapDumpOnOutOfMemoryError -XX:-OmitStackTraceInFastThrow -Dawt.useSystemAAFontSettings=lcd -Djb.vmOptionsFile=./pycharm64.vmoptions -XX:ErrorFile=/home/x/java_error_in_PYCHARM_%p.log -Djb.restart.code=88 -Didea.paths.selector=PyCharm50 -Didea.platform.prefix=PyCharmCore -Didea.no.jre.check=true com.intellij.idea.Main
StartupNotify=false
StartupWMClass=jetbrains-pycharm-ce
OnlyShowIn=Unity;
X-UnityGenerated=true

Several points done in the question was wrong.

1) Running sudo ls /usr/share/applications with sudo is nonsense. Your user can read the data. How do you think you get the icons in Dash? Think about it instead of wildly adding sudo to commands when you don't get what you expect.

2) The files in /usr/share/applications define the files using configuration lines in the files. The filename has no bearing here. You could rename them all to random letters and numbers and Dash would still work as it does now.

3) Try grep -i pycharm /usr/share/applications/* to find out what should be deleted

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.