5

Netflix was working fine until an upgrade updated Chrome to version 48.0.2564.82 (64-bit). It first told me to ensure Widevine was set to "always enabled" in chrome://plugins. After checking "always enabled" it now tells me to check for an update in chrome://components, however it is not in the list of components.

I've deleted the Chrome config (sudo rm -r ~/.config/google-chrome) and rebooted to no avail. Other users on Reddit reported the same thing here: https://www.reddit.com/r/netflix/comments/423a04/all_any_other_linux_users_getting_a_widevine/

Dist: Ubuntu 15.10 (64-bit)

1
  • Interesting. apt-cache-policy for me gives 48.0.2564.82-1 for google-chrome-stable but I do not have this issue on my 64 bit 14.04 system. What can the difference be? – Organic Marble Jan 24 '16 at 3:46
6

I think I figured out this problem. It's related to this issue: https://code.google.com/p/chromium/issues/detail?id=583009

If for some reason you created a launcher on your machine that uses the path to the direct chrome binary like this:

Exec=/opt/google/chrome/chrome

then you aren't running the normal shell script that sets up some library paths to get widevine to work. You can fix it by changing that line to start with:

Exec=/opt/google/chrome/google-chrome

This can happen if you ever started chrome from the command-line and then locked it to your launcher.

This Exec line will be in a .desktop file in

~/.local/share/applications

Usually it will be called "google-chrome.desktop", but it could have other names.

2
  • "This can happen if you ever started chrome from the command-line and then locked it to your launcher." Yep, that's probably what I did. – Chris Feb 2 '16 at 20:24
  • Doesn't seems to be the case anymore. Check with grep -R '/opt/google/chrome/chrome' ~/.local/share/applications. Error code: M7701-1003. – Pablo Bianchi Mar 29 '19 at 4:09
1

I experienced the same problem today. I reverted Chrome to the older version.

NOTE: This will only work when you haven't removed apt's cache with sudo apt-get clean

The old file is at /var/cache/apt/archives/google-chrome-stable_47.0.2526.111-1_amd64.deb. Hence I ran

$ sudo dpkg -i /var/cache/apt/archives/google-chrome-stable_47.0.2526.111-1_amd64.deb

Netflix now works for me!

5
  • Can I force apt to ignore Chrome in the future so it doesn't keep getting updated? – Chris Jan 24 '16 at 3:46
  • 2
    Yes using the "hold" option: $ sudo apt-mark hold goggle-chrome-stable – wsw Jan 24 '16 at 3:47
  • Nice, thanks! It's good to have a workaround. I'd still like to know if Chrome is officially dropping support, or if this is going to be addressed, since keeping an outdated version of Chrome means potentially keeping vulnerabilities around. – Chris Jan 24 '16 at 3:53
  • My question is more about the status of Widevine in the Ubuntu build of Chrome, and whether support is going away for good. But I'll accept your workaround as an answer if nobody is able to answer that. – Chris Jan 24 '16 at 4:01
  • 1
    @wsw can you edit in how to hold Chrome and a note that it only works if you haven't removed apt's cache with sudo apt-get clean, so it becomes something like this – wb9688 Jan 24 '16 at 6:00
0

It also seems to work when upgrading to google-chrome-stable for what it's worth.

Maybe this was a mistake on Google's end?

0

On Firefox 66.0.1 (64-bit) (66.0.1+build1-0ubuntu0.18.04.1) current stable works out of the box, probably since 49+

On Google Chrome

  • google-chrome-stable 73.0.3683.86-1 return Error code: M7701-1003
  • google-chrome-unstable 75.0.3745.4-1

    sudo apt-get install google-chrome-unstable
    killall -s 15 chrome; killall -s 15 chrome; google-chrome-unstable
    

On both cases going to chrome://components/ doesn't list anything about Widevine.

I'm on Ubuntu 18.04.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.