0

I have a directory on my Ubuntu 14 box that I'd like to connect to via my Windows 10 box. I've created a new Samba user, set the new user's password, and verified that the new user has the proper permissions for the directory. When I try map to this drive in Windows Explorer, however, I get an "Access is denied" error. I'd like to use the specific linux user 'music' only - I don't want to make this directory accessible to everyone/guests. 'music' needs to have both read and write access.

I'm using the username music@192.168.1.6 (LAN IP address is static) with the correct Samba password (verified with smbclient).

What do I need to do differently?

Here's the excerpt from my log.elwah file (elwah is the name of my Win10 box):

[2016/01/23 17:59:00.839965,  0] ../source3/smbd/uid.c:153(check_user_share_access)
  user music connection to Music denied due to share security descriptor.

And here is my smb.conf file:

[global]
   workgroup = WORKGROUP
   server string = %h server (Samba, Ubuntu)
   wins support = yes
   dns proxy = no
   encrypt passwords = yes
   log file = /var/log/samba/log.%m
   max log size = 1000
   syslog = 0
   panic action = /usr/share/samba/panic-action %d

   server role = standalone server
   passdb backend = tdbsam
   obey pam restrictions = yes
   unix password sync = yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
   pam password change = yes
   map to guest = bad user
   usershare allow guests = no

   ntlm auth = no
   lanman auth = no
   client ntlmv2 auth = yes

[Music]
   comment = My shared music folder
   path = /mnt/largemarge/music/
   valid users = music
   read only = no
   guest ok = no
  • Who is the owner/group of your music folder? Did you make sure when you created the music user that you have them as part of at least the group that can access your music folder? Just some thoughts. Also, in your [Music] section add in browseable = yes. That is not needed for access, but it does help to add browsing capabilities. – Terrance Jan 24 '16 at 1:36
  • hi @Terrance Yes the music folder is owned by the user 'music' and the group 'music' . I've added browseable = yes , but that hasn't had any effect. – the_meter413 Jan 24 '16 at 1:48
  • Did you by chance try the login without the @192.168.1.6? I don't think the host needs to be specified. I setup just a like share on mine, and it asked for my username and password just fine. I didn't put any @host on it. – Terrance Jan 24 '16 at 1:52
  • I tried both with and without the @host, and no success. – the_meter413 Jan 24 '16 at 1:53
  • OK. Let me see if I can find some old notes of mine when setting up samba shares. – Terrance Jan 24 '16 at 1:53
0

I was able to setup a like configuration with my host, and when I went to access the share through the network browser of Windows 10, it prompted me for my username and password. It only opened up when I gave it the correct information.

Looking at what you have compared to my setup, the following lines I have added to my [global] section of my /etc/samba/smb.conf file:

[global]
usershare owner only = false
unix extensions = no
follow symlinks = yes
wide links = yes

You can also try installing Samba Server Configuration that is a GUI control of your Samba settings by typing in the following:

sudo apt-get install gksu system-config-samba

The gksu is used to launch the Samba Server Configuration application with sudo access.

Hope this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.