I want to install Mongo 3.2 on Ubuntu 15.10.

The official mongodb site gives steps up to 14.04.

On the other hand, using the normal ppa from Ubuntu uses the 2.6 version (which is kinda way too back).

  • I'm fairly certain those instructions will work fine. – TheWanderer Jan 23 '16 at 19:42
  • @Zacharee1 I tried the mongodb site instructions, couldn't find the ppa in ubuntu 15.10 repositories. – KhoPhi Jan 23 '16 at 19:44
  • Try this: gist.github.com/sgnn7/54146c8a13c8b5ca2201 – TheWanderer Jan 23 '16 at 19:46
  • 1
    OK. Replace sudo echo "deb http://repo.mongodb.org/apt/ubuntu "$(lsb_release -sc)"/mongodb-org/3.0 multiverse" with echo "deb http://repo.mongodb.org/apt/ubuntu trusty/mongodb-org/3.2 multiverse". – TheWanderer Jan 23 '16 at 20:21
  • 1
    Yeah. Try it out – TheWanderer Jan 23 '16 at 21:07

Thanks to @Zacharee1, I got 3.2 of Mongo installed on Ubuntu 15.10. Below are the steps taken from LiberianGeek (changed just the version to match 3.2)

Add Key

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv 7F0CEB10

Add Sources List

echo "deb http://repo.mongodb.org/apt/ubuntu trusty/mongodb-org/3.2 multiverse" | sudo tee /etc/apt/sources.list.d/mongodb-org-3.2.list

Update your sources

sudo apt-get update

Install mongodb-org

sudo apt-get install mongodb-org

Check if working

sudo systemctl status mongod

If not working

sudo reboot

If still not working

At the time of writing this, I had Mongo 3.2.1.

Working example. Mongo 3.2.1 on Ubuntu 15.10

| improve this answer | |
  • The key has expired and will give the user a "KEYEXPIRED" error. Use the command in this answer to fix all expired keys in the system. – kba Apr 18 '18 at 13:12

Following the above steps, I got a public key is not available: NO_PUBKEY error

In case this happens to anyone else, I resolved it with:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv EA312927
| improve this answer | |
  • 1
    That's surprising though to me, 'cause I tried the apt-key from my answer, and it still exists. – KhoPhi Jan 31 '16 at 22:28
  • I had the same issue, I did what @adam suggested, it worked. Thanks guys! – biphobe Apr 2 '16 at 12:12
  • I also had this issue, but what worked was adding the key referenced in the error message (e.g. askubuntu.com/a/141088/430924) – D Schlachter Apr 11 '16 at 19:07

For Mongo v3.0 and before you should use this key:

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv 7F0CEB10


For Mongo v3.2 the key has an update:

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv EA312927


| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.