I want to install GNOME Ubuntu on my custom built desktop but cannot get my keyboard to work. I am currently only trying the live CD. It works fine in Windows, the BIOS and GRUB but the moment the Ubuntu starts to load the back lights flash a few times and then it stays on but none of the keys work. This lets me to think that some driver starts which doesn't work well with my keyboard. Is it possible to disable it? Use the same driver as GRUB?

On my Lenovo Y50 laptop with GNOME Ubuntu 15.10 it only works when the kayboard is connected during boot. If I plug it in while the laptop is on it doesn't work at all.

The kayboard is the Gamdias Hermes. I have contacted Gamdias regarding the issue but only received a generic "We do not support Linux" reply. I have tried using both 6-key and n-key roll over.

Other fixes I tried: setting the layout and installing a different driver

lscpu output from my laptop with only the keyboard connected:

Bus 004 Device 002: ID 8087:8000 Intel Corp. 
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 8087:8008 Intel Corp. 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 0cf3:3004 Atheros Communications, Inc. AR3012 Bluetooth 4.0
Bus 001 Device 004: ID 174f:14b8 Syntek 
Bus 001 Device 009: ID 1b80:b403 Afatech 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

xinput list gave the following:

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=17   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ Video Bus                                 id=10   [slave  keyboard (3)]
    ↳ Lenovo EasyCamera                         id=14   [slave  keyboard (3)]
    ↳ Ideapad extra buttons                     id=15   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=16   [slave  keyboard (3)]
    ↳ Kworld GAMDIAS HERMES Gaming Keyboard     id=11   [slave  keyboard (3)]

Any help would be greatly appreciated! I am so excited to move over to Linux permanently thanks to the recent advances in Linux gaming.


I'm not sure if this is applicable to your system, but when I installed Xubuntu on my custom pc I had a similar issue with my USB peripherals. My problem was because of my motherboard: Gigabyte 970a ud3p. What I had to do was to enable IOMMU on the motherboard bios, install xubuntu and then edit one of the system config files. You can check what I did in this video: https://www.youtube.com/watch?v=5Sn8-DUajhM

In my case, not a single USB 2.0 port was working and neither was the network card. Again, I don't know if you have the same problem, but maybe the solution is similar. Try enabling IOMMU in your motherboard (if available) and checking if the keyboard works on the live cd.

  • Thanks for the reply. Would you happen to know what this option is called in ASUS UEFI BIOS? Or is it only a Gigabyte thing? Jan 23 '16 at 22:08
  • Is your CPU AMD or Intel? If i'm not mistaken, IOMMU is the name for AMD cpus. I think on Intel boards it is called Virtualization Technology for Directed I/O (VT-d). Check your motherboard manual or the options you have available in the bios. I think it should be hard to miss. Jan 24 '16 at 1:22
  • I have searched everywhere but cannot find this setting on my Asus P8b75-V board with Intel i5-3570k CPU. I will contact Asus and see if they can help me out. Thanks! Jan 24 '16 at 7:48
  • Hi, mate! I found how for a similar model of motherboard. It seems that in the bios advanced settings, you have to enable "Intel Virtualization Technology". That would be the Intel equivalent to AMD's IOMMU. Just remember that this may not be the solution for your problem, but it is a lead woth checking, in my opinion: i.stack.imgur.com/ttR1U.png Jan 24 '16 at 12:29
  • 1
    Thanks but that unfortunately did not work :( I always have it switched on for Virtual Box. Jan 24 '16 at 12:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.