0

As I wanted to upgrade my wifi connection to N standard I bought EW-7811UN wireless adapter. My ISP provides 100 Mb/s, my wifi router supports N.

The problem is I'm not sure how to make EW-7811UN running on my Ubuntu 14.04 and how to configure it in a way it provides faster wireless connection than 20 Mb/s (which is what I get on my current built-in wireless card).

I tried to install Edimax drivers which gave no result as the installation crashes with errors.

I tried this solution https://askubuntu.com/a/612651 but it looks like the adapter is still not being used by default.

I started to play with drivers, but I did not really understand the process, so it was like shooting in the dark. I finally walked thru steps listed in this answer -> https://askubuntu.com/a/521367/496720 and ended up with nothing

WiFi Info Script Link: http://paste.ubuntu.com/14609460/

Is here anyone willing to help me with setup of this adapter in a way it uses N-WiFi connection?

1

Is the performance of the internal wireless improved if you install the correct driver?

sudo apt-get install firmware-b43-installer
sudo apt-get purge bcmwl-kernel-source

Remove the USB, reboot and let us hear your report.

The connection speed reported by iwconfig and therefor by Network Manager, is notoriously imprecise. My card currently reports 1 Mbps but will happily download at the maximum available from my ISP. Please test with speedtest.net.

Checking your paste results, I see no obvious reason that either device won't achieve higher speeds. I have three suggestions that may be helpful.

First, I suggest you blacklist the driver for the internal in order to test the USB. From a terminal:

sudo -i
echo "blacklist b43"  >>  /etc/modprobe.d/blacklist.conf
echo "blacklist ssb"  >>  /etc/modprobe.d/blacklist.conf
modprobe -r b43
modprobe -r ssb
exit

Second, I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

gksudo gedit /etc/default/crda

Use nano or kate or leafpad if you don't have the text editor gedit.

Change the last line to read:

REGDOMAIN=IS

Proofread carefully, save and close the text editor.

Finally, check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

  • Done it. No change of performance noticed. 20 Mb/s was checked via speedtest.net and I rechecked it now after this operation - no significant changes (now its around 17 Mb/s) actual infroscript output: paste.ubuntu.com/14632206 – Nepu Jan 24 '16 at 14:43
  • We still see the USB loaded and possibly interfering. – chili555 Jan 24 '16 at 15:01
  • USB removed > reboot > speedtest.net results 16.88/9.82; actual infoscript output: paste.ubuntu.com/14636610 – Nepu Jan 24 '16 at 15:44
  • Please see my edit above in a few moments. – chili555 Jan 24 '16 at 21:49
  • I blacklisted internal wireless drivers, checked the adapter on speedtest.net and it looks that all works perfectly fine. Connection speed raised significantly up to 50/10. This result is more than satisfying for me. @chili555 thank you for your assistance! – Nepu Jan 25 '16 at 22:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.