0

As of now i can only create Access Point (AP) wifi networks with open security. I want to add WPA protection to this hotspot. However whenever i try add this the option is always greyed out. I have tried both nm-connection-editor and kde5-connection-editor. Using them i can succesfully create AP networks. Im attaching an image to show the problem. I have also tried with the same superuser priveleges.Please note that the options save (in network-manager) and ok in kde are greyed out.

enter image description here

enter image description here

enter image description here Please Help.

1

I had issues with the built-in network-manager based Hotspot since a long time, both related to compatibility and security. For instance, Android phones are able to connect only to Infrastructure APs which network-manager doesn't support out of the box (as you pointed out). That's the reason I've written my own Wifi Hotspot in python called hotspotd. Feel free to explore and use it:

Hotspotd

  • Thanks.I m trying to connect a window phone. The terminal says that hotspot is running. However the network never shows up when i search for it in my Windows Phone. – Sayan Jan 23 '16 at 18:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.