-1

I know there are some similar questions in here, but I want to know how did this occur. The Terminal started displaying this after I deleted a folder named root in my home directory, but I assumed that I was only deleting something unnecessary(also I was not asked for authentication). How can I go back to the way everything was before :( ?

Also what will I be missing if I remove thisroot.sh from .bashrc ? following the solution in

bash: config.sh: No such file or directory

~/.bashrc's content:

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
case $- in
    *i*) ;;
      *) return;;
esac

# don't put duplicate lines or lines starting with space in the history.
# See bash(1) for more options
HISTCONTROL=ignoreboth

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# If set, the pattern "**" used in a pathname expansion context will
# match all files and zero or more directories and subdirectories.
#shopt -s globstar

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "${debian_chroot:-}" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
    # We have color support; assume it's compliant with Ecma-48
    # (ISO/IEC-6429). (Lack of such support is extremely rare, and such
    # a case would tend to support setf rather than setaf.)
    color_prompt=yes
    else
    color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
    ;;
*)
    ;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'
fi

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'

# Add an "alert" alias for long running commands.  Use like so:
#   sleep 10; alert
alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases
fi

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if ! shopt -oq posix; then
  if [ -f /usr/share/bash-completion/bash_completion ]; then
    . /usr/share/bash-completion/bash_completion
  elif [ -f /etc/bash_completion ]; then
    . /etc/bash_completion
  fi
fi
source /home/trotteville/root/bin/thisroot.sh
  • Possibly your ~/bashrc refers to the missing file? take a look there – steeldriver Jan 23 '16 at 9:01
  • yes, but as i am a newbie, I have no idea what was stored in the folder "root" {actually i had installed "root"(a statistical software) and i thought i was just removing files related to that}. but whatever the reason behind my problem, presently all I can think of is getting things back to normal – Savarkar Jan 23 '16 at 11:23
  • 2
    Please edit your post to include the contents of your .bashrc file (you can either open it using a text editor or using the command cat ~/.bashrc) – steeldriver Jan 23 '16 at 13:09
  • yeah just pasted it, how do i modify this awful bold fonts? tried posting screenshots but wasn't allowed more than two as I don't have necessary ratings – Savarkar Jan 24 '16 at 11:11
  • I've done that for you, see here. – kos Jan 24 '16 at 11:12
0

The problem is in this line:

source /home/trotteville/root/bin/thisroot.sh

which tries to source /home/trotteville/root/bin/thisroot.sh, which doesn't exist.

The fix is simply to remove the line.

  • thanks it works :) just one more query though,by removing that line will I be missing out on anything? or was the file thisroot.sh in /home/trotteville/ . . . . there for some functions which can't be performed anymore because of the deletion of the said "root" folder in /home/trotteville ? – Savarkar Jan 24 '16 at 11:52
  • @ParthaBasumallick That I have no idea about, but since the file doesn't exist you're not missing out anything you weren't before ;) – kos Jan 24 '16 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.