36

Just starting to use Unity with 11.10, and obviously there are a lot of changes to get used to. One of the most annoying is the habit it has of trying to maximize a window when I drag it up against the top bar to position it.

How do I disable this behaviour? I assume there's a toggle in CCSM somewhere, but I can't find it.

5
  • this works for 11.04 classic desktop as well and has nothing to do with unity.
    – Alvar
    Nov 18 '11 at 21:08
  • 2
    Great, I have been looking for how to disable this annoyance for so long, just didn't know what it was called! Even posted the same question which went unresolved.
    – Marcos
    Apr 19 '12 at 20:48
  • These solutions don't work for me. Windows still automatically expand when they're pulled close to the top edge. It's quite annoying. I wonder why someone thought it would be a good idea. kentfx
    – kentfx
    Oct 28 '17 at 11:43
  • 1
    These don't work for me either. I am using ubnutu 17.10. Does anyone have any idea how to toggle this feature?
    – veo
    Jan 26 '18 at 14:53
  • I switched to cinnamon. It solved.
    – veo
    Jan 27 '18 at 2:02
25

Recommended

If you simply want to turn off this feature then run the following in a terminal:

gconftool-2 --set /apps/compiz-1/plugins/grid/screen0/options/top_edge_action --type int 0

Alternatively - with a GUI, use gconf-editor:

Compiz configuration options

2
  • 1
    Great, this is exactly what I was looking for, thanks. I like the grid keypad actions, so just setting the thresholds to 0 gives me the behaviour I want.
    – unit3
    Oct 26 '11 at 20:01
  • While it's nice to have a non-compiz answer, I personally prefer BinaryLife's answer -- the GUI version. It exposes more related settings and you're not poking at numeric values.
    – Jeff Ward
    Apr 5 '16 at 15:33
35

You can disable it from ccsm : Click to install

Go to Windows management--> Grid --> Edges --> Re-size Actions

Top Edge: change it to none.

enter image description here

5
  • Anytime,Glad to help!
    – Binarylife
    Jun 4 '11 at 18:03
  • 2
    Very good. I switched off all edges to get rid of that when I pull the window to another desktop.
    – Bevor
    May 15 '13 at 15:42
  • 1
    Still valid for 16.10 and 17.04. Works like a charm! Dare I say it? Yes. I will Thank you! This was driving me crazy.
    – Orian
    May 14 '17 at 8:16
  • how is that in KDE?
    – SL5net
    Sep 25 '20 at 6:38
  • in KDE Alt+Space type Edges to find 'System Settings' for 'Screen Edges'
    – SL5net
    Sep 25 '20 at 6:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.