12

This question already has an answer here:

Since I have installed Ubuntu 15.10 I can no longer add ppa to my repository list:

@:~>sudo apt-add-repository ppa:git-core/ppa
Cannot add PPA: 'ppa:~git-core/ubuntu/ppa'.
ERROR: '~git-core' user or team does not exist.

Does somebody know what changed in 15.10? Maybe it is an issue with a proxy-server. I am behind a proxy server, but everything else like wget or apt-get is working with my current configuration.

marked as duplicate by David Foerster, karel, Anwar, amc, Eric Carvalho Sep 11 '16 at 0:06

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 3
    This is not a duplicate. The cause of the issue is lack of network connectivity. Solutions may include setting up a proxy server, but they also include not doing that and fixing your network. – mikemaccana Mar 31 '17 at 10:38
  • 1
    I added a print(e) to the catch block in def _get_https_content_py3 in /usr/lib/python3/dist-packages/softwareproperties/ppa.py to get the actual error – gary69 Feb 18 '18 at 23:10
13

You need to export environment variable first. Open a terminal and run:

export http_proxy="http://username:password@proxy:port/"
export https_proxy="https://username:password@proxy:port/"

Now add the PPA:

sudo -E add-apt-repository ppa:git-core/ppa

You will get a prompt:

➜  ~ sudo -E apt-add-repository ppa:git-core/ppa
 The most current stable version of Git for Ubuntu.

For release candidates, go to https://launchpad.net/~git-core/+archive/candidate .
 More info: https://launchpad.net/~git-core/+archive/ubuntu/ppa
Press [ENTER] to continue or ctrl-c to cancel adding it

Press Enter and you will be able to install from a PPA.

  • It should be: sudo -E add-apt-repository ppa:git-core/ppa – Ankit Shubham Jan 20 '17 at 17:07
3

OP's answer

I found the problem, it was really related to the proxy-server but with a different background. Our server uses authentication which was not set up here. After disabling it, the problem went away. The strange think is the misleading error message. So hopefully this will read somebody in the future with the same problem.

  • You mean you have to disable the authentication in your proxy server? – Wins Jan 30 at 5:06

Not the answer you're looking for? Browse other questions tagged or ask your own question.