I am not sure if i am in the right forum for this, because it's more of a debian/kernel thing, but it is worth a try.

I have to set up a linux system to work with EtherCAT ( for a machine control ). I need a Real time einvironment for that. The latest supported Kernel for EtherCAT is 3.4.x. in my case i downloaded the 3.4.110 and the 3.4.110-rt138 real-time patch. I have downloaded and installed the Packages: linux-source, build-essential, kernel-package, libncurses5-dev. So far so good. Now to my Problem: I run the commands: 'tar xf linux-3.4.110.tar.xz' 'cd linux-3.4.110' 'tar xf ../patches-3.4.110-rt138.tar.gz | patch -p1' 'make menuconfig' -> Change settings for a real-time environment ( preemmptible kernel(low latency desktop) ; the rest seems to be preset by the patch) 'make-kpkg clean' 'CONCURRENCY_LEVEL=9 make-kpkg --initrd kernel_image kernel_headers'

Now it starts compiling and everything seems to work, but after a while it stops and i get the following error: ' make[1]: Leaving directory '/home/jasper/sources/Projekt_Ethercat/linux-3.4.110' debian/ruleset/targets/common.mk:295: recipe for target 'debian/stamp/build/kernel' failed make: *** [debian/stamp/build/kernel] Error 2 '

I compiled the 4.1.15 kernel the same way (with rt-patch) and everything worked out fine. I am sitting here for two days straight trying to solve this problem, but i do not have a clue how. Even google fails to provide me an answer. It would be nice if anyone has an Idea or knows how to get this thing to work.

Thank you very much in advance!

Best regards, Mitja

P.s. Im running Xubuntu 15.10

1 Answer 1


I would suggest running the compilation without CONCURRENCY_LEVEL.

Error 2 is rather general error, but the real cause is probably hidden somewhere up the compilation output. If you run it in non-parallel mode, you should be able to spot any other error message (from GCC for example) much easily.

Best regards, Pavel

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.