I want to start my virtual machine but in VirtualBox Manager, it says it's inaccessible and that I should be inspecting the error log which says:

Document is empty.
Location: '/home/ron/VirtualBox VMs/Semios Win7 /Semios Win7 .vbox', line 1 (0), column 1.
/home/vbox/vbox-5.0.12/src/VBox/Main/src-server/MachineImpl.cpp[740] (nsresult Machine::i_registeredInit()).
Result Code: 
NS_ERROR_FAILURE (0x80004005)
IMachine {f30138d4-e5ea-4b3a-8858-a059de4c93fd}

The only problem is, I don't know how to interpret what I'm seeing. What does all this mean?

  • 2
    Are you sure about the trailing space in the name? What does VBoxManage list vms say? Jan 22 '16 at 6:04

Go to the location where you store your VM /home/ron/VirtualBox VMs/Semios Win7 /.

Open .vbox in your favorite text editor to check if it is empty. Probably it is :) In the same folder you should have file Semios Win7 .vbox-prev. Copy the contents of this file to Semios Win7.vbox, save, and try again.

Now it should work. I did the same and it worked for me.

  • what to do if its in ubuntu?
    – kashminder
    Jun 9 '16 at 11:54
  • @kashminder Do the same thing. Just check what is your main folder for storing virtual machines data. If you don't know it do this in Virtual Box GUI: New > check "use existing virtual hard disk file" > click the folder icon > tadam, this is your root folder.
    – TheKalin
    Jun 10 '16 at 14:07
  • its the same still. working for the root user but not with logged in one.
    – kashminder
    Jun 12 '16 at 11:43
  • @kashminder Check your permissions than. ls -l your vm folder. Add user to sudo or change permissions for vm files.
    – TheKalin
    Jun 13 '16 at 13:59
  • 4
    @user240891 In my case i ran out of space on disk and had to reboot. After reboot that file was 0kb.
    – TheKalin
    Jun 20 '17 at 12:06

Not the answer you're looking for? Browse other questions tagged or ask your own question.