1

For some reason my Ubuntu 14.04 installation does not recognize my screen and therefore won't set the correct resolution. It defaults to something huge like 640x480.

I found a way to set the required setting as follows:

cvt 1920 1080 60
xrandr --newmode "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
xrandr --addmode VGA1 "1920x1080_60.00"

which I ran in a terminal.

Unfortunately, this does not set the settings permanently and I have to re-run each line after reboots.

How/Where can I set these lines/settings as default?

lspci -v | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller]) 

The commands above worked well until I did a complete new install with the latest OS core. Now I get: "cvt 1920 1080 60 # 1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz Modeline "1920x1080_60.00" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync"

"xrandr --newmode "1920x1080_60.00" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync X Error of failed request: BadName (named color or font does not exist) Major opcode of failed request: 140 (RANDR) Minor opcode of failed request: 16 (RRCreateMode) Serial number of failed request: 28 Current serial number in output stream: 28" What has changed? Or better yet, what should I change to get it working again? All help is greatly appreciated. Kind regards.

4

You can reconfigure xOrg. I did this by creating a file in my /usr/share/X11/xorg.conf.d Directory.

I made it using vim:

sudo vim /usr/share/X11/xorg.conf.d/5-monitor.conf

Here is an example of my file

Section "Monitor"
   Identifier "Monitor0"
   Modeline "1920x1080_60.00" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
   Modeline "3840x2160_30.0" 297.00 3840 4016 4104 4400 2160 2168 2178 2250 +hsync +vsync
   Modeline "4096x2160_24.0" 297.00 4096 5116 5204 5500 2160 2168 2178 2250 +hsync +vsync
EndSection
Section "Device"
   Identifier "Device0"
   Driver "intel"
EndSection
Section "Screen"
   Identifier "Screen0"
   Device "Device0"
   Monitor "Monitor0"
   DefaultDepth 24
   SubSection "Display"
      Depth 24
      Modes "3840x2160" "1920x1080"
   EndSubSection
EndSection

For directions on how to do this you can follow this tutorial: https://wiki.gentoo.org/wiki/Xorg/Multiple_monitors

I was ran into this issue with ubuntu 16.0.4

0
xrandr --addmode VGA 1920x1080_60.00

Only Last tell a reboot you can make it permanent

.xprofile 

Just copy and paste the xrandr command line strings into your user ~/.xprofile file so it executed when you log in

  • 2
    Maybe for root as well , i.e. /root/.xprofile, to also apply for the login screen? – Ralph Rönnquist Jan 21 '16 at 23:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.