After upgrading from 11.04 to 11.10, I've noticed that the "Take Screenshot" application used to be launched when I'd hit print screen. Now it automatically captures the entire screen. In 11.04 it would pop up the "take screenshot" application which allows me to capture a rectangular region of the screen.

Can this be reverted? I never want to capture the whole screen, only portions of it, which means manually cropping out that section in GIMP with this changed behaviour.


  • ahh...looking at the launch options of the "screenshot" program in the application menu, it invokes "gnome-screenshot --interactive". If I just call "gnome-screenshot" from the command line then it captures the entire screen, just as it does with print screen key. Seems I need to change the command that's issued when hitting print screen Oct 26 '11 at 15:49

This is already built in. To take a region screenshot, just use SHIFT-Printscreen. It will then allow you to drag a square on the region you desire.

  • This still works in 14.04
    – kasperd
    Oct 29 '15 at 8:26

One way to fix this is by installing compizconfig-settings-manager

sudo apt-get install compizconfig-settings-manager

Then when you open the settings manager go to the "Gnome Compatibility": enter image description here

And the add he interactive "-i" switch to the print command: enter image description here

After that pressing PrintScreen should open the dialog you want.


  • gnome-screenshot is faster, easier to understand, has a lighter memory footprint, and comes pre-installed. It is arrogant of you, not to mention off-topic, to suggest with such conviction that the author's needs would be better met by a feature-rich screenshot tool.
    – ændrük
    Oct 26 '11 at 15:40
  • 1
    I changed my answer so that it is now a real answer. Sorry if I offend someone. I am trying to help.
    – lpanebr
    Oct 26 '11 at 16:22
  • 1
    Brilliant - this worked a charm. Thanks very much! Oct 26 '11 at 16:26
  • 1
    @lpanebr Thanks, and awesome job. You have my vote.
    – ændrük
    Oct 26 '11 at 16:37

Really? Seems to work in Ubuntu 11.10.

enter image description here

  • 1
    Pressing print screen pops up a window where you choose where to save it to, no option for screen regions. Oct 26 '11 at 16:22

I think you are thinking about the GNOME program called Shutter.

You can install it by opening a terminal and running:

sudo apt-get install shutter

This program allows you to take screenshots by selecting areas of your screen, as well as being able to screenshot menus, tooltips, websites, and more.

EDIT: Just found this. Was this what you were talking about? You may need to install Compiz Configuration Settings Manager. In the terminal:

sudo apt-get install compizconfig-settings-manager

I'm not familiar with the default behavior of Print since I have allowed Shutter to override it, but if it's not working how you'd like it to it's simple enough to redefine it:

  1. At System Settings ▸ Keyboard ▸ Shortcuts ▸ Custom Shortcuts, click the + button.
  2. Enter any name you want and the following command, then click Apply:

    gnome-screenshot --interactive
  3. Click on the word Disabled, press Print, then click Reassign if prompted.

  • 1
    wow, that's great. However, it doesn't seem to have worked. I have disabled the two commands under the "screenshots" shortcut tree on the left...damn Oct 26 '11 at 16:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.