I got a Lenovo Yoga 3 11 and installed Ubuntu 15.10 trouble is

  • no wifi
  • no ethernet (computer is too thin)

I've heard this is a very specific bug. After some reading I have a Qualcomm Atheros Device but forget the exact number. Other questions address the Broadcom case.

After downloading the CD image, I installed a dual boot partition with Windows 10 and Lenovo has the wireless driver for Windows.

Writing this question from my phone will continue to supply more details.


Ubuntu 14.04 Wireless not working: no network interface. Atheros [168c:003e] device (solution was to upgrade to 15.10)

No WiFi on Lenovo Yoga 3

lspci -nn | grep 0280
02:00.0 Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 20)


https://github.com/kvalo/ath10k-firmware ath10k installation

I have no idea what these do or if they are correct

One possible hardware solution is usb ethernet adaptor but guess what? No internet no cd rom so i can't download http://www.asix.com.tw/products.php?op=pItemdetail&PItemID=86;71;101&PLine=71

dpkg -l | grep "linux-firmware"
ii linux-firmware 1.149 all Firmware for Linux kernel drivers
  • Please edit your question and add output of lspci -knn | grep Net -A2; rfkill list terminal command. – Pilot6 Jan 21 '16 at 13:05
  • @pilot6 this is hard to do from my phone. One moment please – john mangual Jan 21 '16 at 13:32
  • You can enable wifi by using the first two commands from my answer. Everything else will be much easier with an internet connection. – Pilot6 Jan 21 '16 at 13:37
  • I asked for a bit different command ;-) – Pilot6 Jan 21 '16 at 13:41
  • @pilot6 wifi does not work even after modprobe and rfkill – john mangual Jan 21 '16 at 14:04

Your wireless driver requires firmware that is not installed by default. Please download this file on some other computer and transfer it with a flash drive or similar: http://archive.ubuntu.com/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.149.3_all.deb

Transfer it to the Ubuntu computer and drag and drop it to the desktop. Now, on the Ubuntu computer, open a terminal and do:

cd ~/Desktop
sudo dpkg -i linux*.deb

After it is done, please do:

sudo modprobe -r ath10k_pci
sudo modprobe ath10k_pci

Your wireless should be working but it might take a reboot.

  • I am afraid this will not help. By default Ubuntu 15.10 contains 1.149.2 firmware that contains the same files related to ath10k as 1.149.3. – Pilot6 Jan 21 '16 at 16:35
  • +1. But I have no idea why this worked. – Pilot6 Jan 21 '16 at 20:03
  • Glad it's working by whatever means! – chili555 Jan 21 '16 at 20:12

The wireless adapter is probably blocked by the platform driver.

You can fix it by running

sudo modprobe -r ideapad_laptop
sudo rfkill unblock all

This should unblock it until a reboot.

To make it permanent you can run

sudo tee /etc/modprobe.d/blacklist-ideapad.conf <<< "blacklist ideapad_laptop"

This will permanently disable the platform driver.

A better solution is to report a bug to launchpad by running:

ubuntu-bug linux

and add there output of

sudo dmidecode | grep "System Information" -A8

If you drop a link to the bug report, I will be able to take care of it.

The issue has been fixed upstream, but it needs to be backported to the current Ubuntu kernels.

  • I can't report a bug without Internet. What do you mean "upstream"? The most recent 15.10 kernel I can find dates to October – john mangual Jan 21 '16 at 13:28
  • I mean that in kernel 4.4 it is fixed. Just run the first two commands. That should be fixed. – Pilot6 Jan 21 '16 at 13:35
  • I noticed blacklists for ath-pci and bcm43 but not ideapad_laptop are those relevant? – john mangual Jan 21 '16 at 13:59
  • No internet still – john mangual Jan 21 '16 at 14:03

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.