10

On Ubuntu Gnome 15.10, my mouse cursor leaves strange "trails" all around the screen. This happens when the cursor moves over or leaves a dynamic screen element (anything that changes on hover) such as a link or a toolbar button.

Here's a quick screencast showing what it looks like (posted on YouTube)

Any help to fix this quirk would be appreciated.

  • Also experiencing this. A little more info: it only seems to happen for me when I'm using a second display with my laptop (via HDMI, but I haven't been able to test any other ports). It happens regardless of mirroring/extending and occurs on both displays. Also worth mentioning that the cursor flickers as it's moving and sometimes disappears a short duration. Ubuntu Gnome 16.04 here. – Joseph Mansfield May 13 '16 at 20:21
  • For some reason this stoped happening on my computer once I upgraded to Ubuntu Gnome 16.04. – Phanindra K May 22 '16 at 19:02
  • Happening to me as well after upgrading to 16.04 - super annoying. – Florian Jun 2 '16 at 9:29
  • I was mistaken. It did not stop because I upgraded to 16.04, it looks like it just doesn't happen as long as I have my external display (monitor) set as the primary display on Gnome. For some reason I switched settings and made my laptop display the primary and there it was again. – Phanindra K Jun 4 '16 at 5:01
  • 1
    I had a similar issue where i just had a random square behind my cursor overlaying everything. Restart didn't help, neither any of the suggestions, but for a reason beyond my understanding logging out and back in again resolved it completely. (Note: Restart does not help, you need to boot up, log in, log out, log in and that did it for me). The same applies to a college of mine running kubuntu. I am on 16.04 with nvidia prime enabled on driver 384. – pandaadb Oct 5 '17 at 16:47
2

I had the same problem in Kubuntu 16.04 and got rid of the trails by turning the Tearing / VSync to always redraw everything (System Settings > Display > Compositor). You get also rid of the trails by turning off OpenGL (also found in the Compositor settings), but then you lose hardware acceleration.

| improve this answer | |
  • OP uses GNOME. But in general, enabling VSync to redraw all could be a solution. – UniversallyUniqueID Jun 6 '16 at 16:03
  • Thanks, been looking for a solution for a while. Should anyone need help in Kubuntu 14.04, the settings are under System Settings -> Desktop Effects -> Advanced. I was stuck on Xrender compositing type, changing that to OpenGL3.1, and setting Tearing prevention (Vsync) to Full scene repaints fixed it for me. It seems KDE enjoys changing where to find configuration options with every new release, I wonder why. – MariusMatutiae Oct 17 '16 at 20:57
2

Thanks to Mark's answer which led me to look for ways to configure Gnome to redraw everything on vsync, I finally found a fix for this in Gnome. Just add this line to your /etc/environment file:

CLUTTER_PAINT=disable-clipped-redraws:disable-culling

I am finally free of cursor trails and screen tearing in Ubuntu 16.04 with Gnome 3.18.2.

| improve this answer | |
  • 1
    Didn't work for me on Ubuntu 18.04 with Gnome 3.28.2 – Lucas Bustamante Jul 2 '19 at 16:24
1

I had a problem with screen tearing just after upgrading Kubuntu 16.10 to 17.04. Answers from Joseph and comment from MariusMatutiae (under Mark's answer) helped me but I had to use both solutions together. To sum up I:

  1. Went to System settings > Display and Monitor > Compositor
  2. Set Rendering backend to OpenGL 3.1
  3. Set Tearing prevention ("vsync") to Full screen repaints
  4. Added CLUTTER_PAINT=disable-clipped-redraws:disable-culling in /etc/environment
  5. Logged out and logged back in
| improve this answer | |
1

Same problem with Ubuntu 18.04LTS that installed KiCad 4.0.7. Fixed with installing KiCad 5 from http://kicad-pcb.org/download/ubuntu/ .

NB: you don't really download from the KiCad home site, but using the instructions for Ubuntu, you add a download site to your software downloader with a PPA. Then use 'apt' to install KiCad 5. Pretty simple procedure with simple instructions. This way, you will automatically upgrade to new versions like any other Ubuntu packages.

| improve this answer | |
  • What is Kicad ? – Lucas Bustamante Jul 2 '19 at 16:25
  • @LucasBustamante a free software suite for electronic design automation (EDA). On the wikipedia page for KiCad you will find their web site. – Roland Jul 3 '19 at 9:06
0

I just had this problem with Linux Mint 18.2 (based on Ubuntu 16.04) freshly installed and running Cinnamon. One monitor is plugged to my i7 Sky lake and one is on a Radeon R7. I updated the kernel to the new 4.13 released yesterday but it didn't changed anything. I tried to switch the main monitor, no result. I don't have a the compositor setting in Cinnamon, but I know this was a GPU driver problem, to repaint everything everytime didn't look like a nice solution. So I updated Mesa from 17.0.2 to 17.1.2 (even if it's still OpenGL 3) and then activated DRI3 instead of DRI2 (following this wiki page) and TADA! No artifacts anymore!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.