0

I just set up Evolution 3.16.0 in Ubuntu GNOME 15.04. I have a Gmail account, two Outlook.com accounts, and an iCloud account. All accounts work fine in Thunderbird on my Windows laptop and on my iPhone.

Gmail, iCloud, and one of the Outlook.com accounts work fine in Evolution, but the other Outlook.com account only imported some of my older emails. It also also gives the error "Error fetching message headers: unexpected server response." The settings on both Outlook.com accounts are the same in Evolution.

Any advice would be greatly appreciated!

  • Have you tried running evolution from the command line? That should give more insight about the real issue. If you don't see that even like that, try running it in debug mode (wiki.gnome.org/Apps/Evolution/Debugging) – Eduardo López Jan 21 '16 at 8:49
  • From the command line, the error returned when refreshing the Outlook.com Inbox is "camel-imapx-CRITICAL **: imapx_untagged_fetch: assertion 'found' failed". Googling this doesn't really turn up any answers for me. I'll try debug mode. – Michael bean Jan 23 '16 at 21:18
  • Debug mode reveals two errors, but nothing I can understand. I'm surprised how different the logs are between the two accounts. The errors are: "(evolution:8197): GLib-GObject-CRITICAL **: g_closure_unref: assertion 'closure->ref_count > 0' failed" and "(evolution:8197): camel-imapx-CRITICAL **: imapx_untagged_fetch: assertion 'found' failed [imapx:A] Data read failed with error 'unexpected server response:' [imapx:A] I/O: '' [imapx:A] Ignoring timeout error, nothing was waiting (original error: Socket I/O timed out)" – Michael bean Jan 23 '16 at 22:15
  • Maybe I should move this question to the Ubuntu Forum, seems a better way to troubleshoot issues than the reply system here? – Michael bean Jan 23 '16 at 23:00
0

(evolution:8197): GLib-GObject-CRITICAL **: g_closure_unref: assertion 'closure->ref_count > 0' failed

The first issue you report has been already reported as a Webkit-bug as far I can tell - It appears to be already solved and there is a patch availabel at

https://bugs.webkit.org/show_bug.cgi?id=127474

But it shouldn't be causing any issue with email fetching, following that thread:

While loading email into WebView in Evolution with WK1 it's showing this warning. Everything loads and renders fine. I'm on http://trac.webkit.org/changeset/162517

(evolution:21890): GLib-GObject-CRITICAL **: g_closure_unref: assertion 'closure->ref_count > 0' failed

(evolution:8197): camel-imapx-CRITICAL **: imapx_untagged_fetch: assertion 'found' failed [imapx:A] Data read failed with error 'unexpected server response:' [imapx:A] I/O: '' [imapx:A] Ignoring timeout error, nothing was waiting (original error: Socket I/O timed out)

The second one suggests evolution is unable to fetch a certain message from the server and I had a similar problem in the past which was caused by the fact that Gmail does not really delete emails from the server under certain circumstances:

https://support.google.com/mail/answer/78755?hl=en

If you delete a message from your inbox or one of your custom folders in your IMAP client, it will still appear in [Gmail]/All Mail.

Here's why: in most folders, deleting a message simply removes that folder's label from the message, including the label identifying the message as being in your inbox. [Gmail]/All Mail shows all of your messages, whether or not they have labels attached to them. If you want to delete a message from all folders, move it to the [Gmail]/Trash folder.

Accordingly, Evolution tries to fetch a message which actually does not exist in the specified location/folder, thus receiving an unexpected server response from the server.

Anyway, the problem was solved by deleting the file

/home/<user>/.cache/evolution/mail/<profile>/folders.db

which in essence should be the same as DELETING THE EMAIL ACCOUNT.

I'd strongly suggest to do that after backing everything up. If you already deleted the account and created it again, delete the folders.db file manually (with evolution closed) and start evolution again. It should then rebuild the folder structure and information from the server for all accounts.

|improve this answer|||||
  • The account in question is with Outlook.com, not Gmail. However, I deleted all accounts from within Evolution, verified that the files were gone in the folder you pointed to, and re-added the one Outlook account. It still didn't solve the issue. I uninstalled Evolution Mail & Calendar (and Evolution Calendar-oops! Don't do that! It boots to a command prompt instead of GUI.) then I reinstalled evolution and re-added the Outlook account. Still not working... – Michael bean Jan 26 '16 at 5:28
  • Hmm... I'm still somehow convinced it has to be a problem with a certain email. Can you please check if you got a System eMail from outlook like undeliverables, relays, read receipts or similiar stuff and just wipe them if you don't really need them? I remember a case also in Ubuntu with another email client which was unable to sync because it was unable to process an undeliverable message and crashed until that email was deleted. Maybe its worth a try! Otherwise, I'm clueless and you might want to report a bug at projects-old.gnome.org/evolution/bugs.shtml – Eduardo López Jan 26 '16 at 9:27
  • Just saw the newest version available in the Ubuntu repositories is the 3.16 while Evolution's newest version is the 3.18. You could try using the newest version instead and see if the problem gets solved. Here you can find its release notes: news.softpedia.com/news/… – Eduardo López Jan 26 '16 at 9:32
  • By the way... Did you try to set up the account with another protocol? Maybe POP3 or EWS (The one I use for Outlook - Evolution has a plugin for it) would prove better? Cheers – Eduardo López Jan 26 '16 at 9:43
  • The default IMAP setting match Outlook.com's instructions, so I only changed them while troubleshooting. Maybe I'll try the upgrade route. Thunderbird is working fine on this computer, but I like the look/integration of Evolution and it's good to try new things! Thanks for your suggestions! – Michael bean Jan 27 '16 at 21:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.