After adding some default security packages and changing my cursor theme, the whole Unity Launcher gets walloped and is gone when logging in, which seems a bit wonky for Unity.

Tried to run unity --reset in a separate terminal but with the default X running, not certain if I need to drop to recovery first to try this procedure.

Actually seems that having the whole Unity package with size 48 icons by default is a mess, would be much better to be able to modify to suit and tweak the interface to my needs.

Surprised this release is this fragile, has never been my experience to date with Ubuntu since the early days of 6.x releases.

Trying to love Unity, but this one is a bit fragile if it can not be easily recovered and restored on modern hardware. Glad to supply any necessary documents, logs and/or information to determine cause/solutions.

AMD Phenom Quad Core 960 HT 3GHz 64-bit 11.10 install on 9th iteration trying to determine which package is the killer.

The AMD Radeon graphics detection in jockey is particularly confusing at the moment as well, as the post-release update package continues to detect as necessary, but have found this will always fail and will leave remainders in place.

Avoiding the second install of that demand like the plague now, but will confuse users, and not certain if order of that install matters or causes issues.

1 Answer 1


Per http://www.webupd8.org/2011/10/things-to-tweak-after-installing-ubuntu.html

Something went wrong! How do I reset Unity or Compiz?

You can easily reset Unity or Compiz using the following commands (be careful when using these commands and only use them if you really have to!):

  • to reset the Unity launcher icons:

    unity --reset-icons
  • to reset Unity:

    unity --reset
  • to reset Compiz:

    gconftool-2 --recursive-unset /apps/compiz-1
    unity --reset
  • 1
    I see on second glance that you tried unity --reset. You may want to follow that with a restart. Oct 26, 2011 at 17:02
  • Thanks @Argusvision, finally managed to pound through an install that stablised at last. Just had to stop at a CompizConfigSettingsManager setting and not choose the Crash Handler. Think the problem with the unity --reset may be that it does require dropping out to the recovery console to perform. Would not seem to complete when booted and on one of the virtual terminals with any sort of XWindows running anywhere (had blackbox up then switched to a separate virtual console, but still, that "unity --reset" seemed to hang at the end. Odd that. All is well that ends well. Have a nice day.
    – freecode
    Oct 26, 2011 at 18:13
  • @freecode It sounds like your issue has been resolved, but you have not accepted an answer yet. Please consider accepting this answer if it resolved your problem so we know a solution has been found. You can do so by clicking the checkmark icon to the left of the desired answer. Thanks! Nov 27, 2011 at 2:41
  • Thanks to @Argusvision for the original answer not sure if I marked the right answer here. Just got back from a funeral for my brother-in-law and trying to respond to questions and answers again.
    – freecode
    Nov 30, 2011 at 13:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .