The touchpad of my laptop fails to work soon after I login to Ubuntu. I've gone through several threads in forums regarding the same matter and have tried out:

gconftool -set boolean ... command

I've even tried to reboot the system in recovery mode. I've unchecked the System -> Preferences -> Enable touchpad while key type and restarted as well.

None of the above methods which did work for few seem to work for me. Please help me. How can I fix the touchpad issue in Ubuntu 11.10 without a reinstall?

I am using 64 bit Oneiric, on an Dell Inspiron


I had similar issue, my touchpad was working in a super basic (move and click only) mode.

After reading all the comments on https://bugs.launchpad.net/linux/+bug/550625/ I got it to work by installing Seth's psmouse-alps-dkms_0.10_all.deb from comment #492:

Now I have:

  • touchpad preferences in system settings
  • two finger vertical and horizontal scroll
  • tow finger right-click

My touchpad is "AlpsPS/2 ALPS DualPoint TouchPad".

Find out your touchpad brand running:

xinput list

good luck!


| improve this answer | |

I've only seen this happen sporadically on a Dell latop. While disabling the "Disable touchpad while typing" seemed to help, the best solution here was to set this also.

gsettings set org.gnome.settings-daemon.plugins.mouse active false    

An active bug on https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/868400

| improve this answer | |

I had the exact same issue, I found a blog that had a command that actually fixed the issue synclient TouchpadOff=0

I ran the command as sudo synclient TouchpadOff=0, and it worked, exactly a

| improve this answer | |

I've tried running in a terminal sudo modprobe -r psmouse && sudo modprobe psmouse and it worked.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.