0

I'm trying to install Arch Linux for a Raspberry Pi 2 according to their instructions on http://archlinuxarm.org/platforms/armv7/broadcom/raspberry-pi-2 on a brand new 64G micro-SD card. I'm doing so using an Oracle VM Virtual Box with Ubuntu v14.04 LTS within a Windows 7 environment. I'm somewhat inexperienced with Ubuntu and Linux in general. Also, SD card and the reader that I'm writing to were VERY cheap from China via ebay, so I'm suspicious of a problem with the SD card at this point.

Anyway, after formatting the disk and creating partitions using fdisk seemingly without incident, I get to step 4 in the Arch instructions, which says to do the following:

mkfs.ext4 /dev/sdX2
mkdir root
mount /dev/sdX2 root

the result I get is:

mount: wrong fs type, bad option, bad superblock on /dev/sdb2, 
missing codepage or helper program, or other error 
In some cases useful info is found in syslog - try 
dmesg | tail or so

dmesg | tail gives the following:

[ 6231.419388]  sdb: sdb1 sdb2
[ 6275.385637] JBD2: no valid journal superblock found
[ 6275.385644] EXT4-fs (sdb2): error loading journal

I found a few other questions with similar problems, such as this, this, and this but none of them have solved my problem.

What is going on?

  • mount typically requires the --types option , also known as -t . Try this mount -t ext4 /dev/sdb2 root. Perhaps partitioning went wrong somewhere. Try reformating the card and starting from scratch. If you don't mind me asking, why would you like to install Arch ? ( Not taking any distro sides here, just offering a possibility of trying other OSs , such as Raspbian or Mate , for considerations ). Arch installations can be tricky and certainly not for newcomers to the linux world – Sergiy Kolodyazhnyy Jan 21 '16 at 4:24
  • I've used arch before. I actually have more arch experience than any other Linux distro. I think it's well suited for embedded applications where I want the most stripped down OS possible. – kjgregory Jan 21 '16 at 4:44
1

you have problems with your mount command please use this

mount -t ext4 /dev/sdX2 /root

If you have any further questions please do not hesitate to ask me.

  • I actually just found a solution elsewhere. I don't have the exact command I used in front of me anymore, but It supposedly made the ext4 filesystem without journals. – kjgregory Jan 21 '16 at 4:48
  • @kjgregory may I suggest posting an answer so that future users may find your solution helpful ? Thanks – Sergiy Kolodyazhnyy Jan 21 '16 at 4:59
  • This is the command that got me past the error message: mke2fs -t ext4 -O ^has_journal /dev/sdb2. My Raspberry Pi doesn't seem to boot up yet, so it seems there is still a problem with my setup. – kjgregory Jan 22 '16 at 3:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.