Update: Section 1 fixed?

Section 1:

Using: https://stackoverflow.com/questions/32493904/could-not-insert-nvidia-352-no-such-device, I was able to get the kernel to read as using nvidia.

I'm trying to install Ubuntu 15.10 with an Nvidia 7300 LE video card. I installed server. Then I ran sudo ap-get update && sudo apt-get upgrade && sudo apt-get install ubuntu-desktop.

I saw some methods for installing drivers for nvidia cards but none that touched on my card and none that worked for my card.

What is a step-by-step guide to getting my desktop to show up with Unity on it? Right now, if I log in, the screen turns black after a few moments, then I get sent back to login.

Do I need to do something with my blacklist? If-so, how? What driver should I use, please?

Ideally, I could find some method of installing a driver and then getting the system to work properly with that driver. I'd prefer not to go through another full installation procedure.


Going through https://websetnet.com/how-to-install-the-latest-nvidia-drivers-on-ubuntu/.

Step 1:

~$ sudo lspci -vnn | grep -i VGA -A 12
05:00.0 VGA compatible controller: NVIDIA Corporation [GeForce 7300 LE] (rev a1) (prog-if 00 [VGA controller])
        Subsystem: Micro-Star International Co., Ltd. [MSI] 7300LE PCI Express Graphics Adapter [1462:0345]
        Flags: bus master, fast devsel, latency 0, IRQ 30
        Memory at fd000000 (32-bit, non-prefetched) [size=16M]
        Memory at d0000000 (64-bit, prefetchable) [size=250M]
        Memory at fc000000 (64-bit, non-prefetchable) [size=16M]
        Expansion ROM at feae0000 [disabled] [size=128K]
        Capabilities: [60] Power Management version 2
        Capabilities: [68] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [70] Express Endpoint, MSI 00
        Capabilities: [100] Virtual Channel
        Capabilities: [128] Power Budgeting <?>
        Kernel driver in use: nouveau

Step 2:

http://www.nvidia.com/page/geforce_7300.html says "GeForce 7 Series"; http://nvidia.com/drivers says GeForce 7 Series for Linux's driver is 304.

Step 3:

Done and re-done.

Step 4:

I'm not sure if I should be installing 304 AND latest, but that's what I've done (run both):

# 304 driver
$ sudo apt-get install nvidia-334
# install the latest version
$ sudo apt-get install nvidia-current

!Step 5

The last line says Kernel driver in use: nouveau, and it should say Kernel driver in use: nvidia, according to the link.

So, I tried:

modprobe -rv nouveau && sudo modprobe nvidia
!modprobe: ERROR: could not insert 'nvidia_304': No such device

This final line has me completely vexed. I'm positive it's a 7300 LE, which is certainly a 7-series. So, why is terminal lying to me?

[Fix?]: Well, I used https://stackoverflow.com/questions/32493904/could-not-insert-nvidia-352-no-such-device. Now it says the kernel is using nvidia; however, I have the same issue I started with, still (I'll upload a video).

Section 2

After I type in the password at the ubuntu 15.10 login screen, the login dialog disappears, as does the top bar. The mouse cursor is still present....

After a fwe moments, "System program problem detected: do you want to report this problem? Report / Cancel" appears. I reported it.

The PC is running extremely slowly and clunkily. The desktop often turns black. I'm getting crashes for everything I open. It seems like a video card issue, to me. Then, the system restarts itself.


For your GPU, its' in the legacy maintenance state and the latest driver supporting it is the R304 series.

You can install it on your system by running apt as a privileged user:

apt install nvidia-304 nvidia-304-dev

Note that the nvidia-304-updates that you're being referred to is a transitional package that lacks support for your GPU in the first place.

At this time, installing the package above may downgrade some components (such as xorg and other libraries) to fulfill its' dependencies, judging by the driver's age.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.