I need to install Emgu CV, a .NET wrapper for OpenCV, for my robotics programming class at the instructor's request. The documentation for this software indicates that it is cross-platform and can be used on Ubuntu using MonoDevelop, but requires compilation first. Since my laptop only runs Ubuntu, this what I'm attempting to set up.

I got through compiling the library just fine and was even able to successfully run the test .monoexe application it comes with, but the problem I'm having is with trying to install the generated .deb package. When I navigate into the ~/emgucv directory after building the package and run the following command to install it from the command line, just like any other package:

sudo dpkg -i libemgucv-x64-tbb-

...the package fails to install due to dependency issues, and requires me to run apt-get install -f to fix my package system:

Selecting previously unselected package emgucv-x64-tbb.
(Reading database ... 301667 files and directories currently installed.)
Preparing to unpack libemgucv-x64-tbb- ...
Unpacking emgucv-x64-tbb ( ...
dpkg: dependency problems prevent configuration of emgucv-x64-tbb:
 emgucv-x64-tbb depends on libmono-wcf3.0-cil; however:
  Package libmono-wcf3.0-cil is not installed.
 emgucv-x64-tbb depends on libavcodec53; however:
  Package libavcodec53 is not installed.
 emgucv-x64-tbb depends on libswscale2; however:
  Package libswscale2 is not installed.
 emgucv-x64-tbb depends on libavformat53; however:
  Package libavformat53 is not installed.
 emgucv-x64-tbb depends on libopenexr6; however:
  Package libopenexr6 is not installed.

dpkg: error processing package emgucv-x64-tbb (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:

How can I resolve these errors and properly install the package? The documentation seems to indicate that the installation instructions have not been updated since Ubuntu 11.04/14.04 LTS, but I'm trying to install this on Ubuntu 15.10. Help would be much appreciated — if I can't get this to work, I'll be forced to use Windows and Visual Studio instead.

closed as off-topic by Pilot6, Zanna, Anwar, Eric Carvalho, Kevin Bowen Sep 6 '16 at 23:28

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Pilot6, Zanna
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Have you triend installing the dependencies with apt-get? (You are given the names of the required packages.) – fkraiem Jan 20 '16 at 23:42
  • @fkraiem When I do, I get errors for each of them like Package libavcodec53 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source. – Christopher Kyle Horton Jan 21 '16 at 0:58
  • Yes obviously the package is for 11.04, so its depends on packages which are in the 11.04 repositories and not in the 15.10 ones... You could try to modify the dependencies of the package before building it (in debian/control) but this may not work if the package is not compatible with the mor e recent versions of the libraries. – fkraiem Jan 21 '16 at 1:04
  • 2
    Possible duplicate of How do I install a .deb file via the command line? – Luís de Sousa Jan 21 '16 at 20:22
  • @LuísdeSousa This is not a duplicate of that; I already know how to install .deb files in general via dpkg. The problem here is this specific package. – Christopher Kyle Horton Jan 22 '16 at 1:17