0

I am fairly new to Ubuntu ( I have been using it for about a week and a half). I am using 14.04 LTS 64-bit. I immediately installed a bunch of apps. Everything was working well. I tried out a couple of other desktops (GNOME 3 and LXDE) and they both worked fine. I tried to install Pantheon with this tutorial:

http://tuxdiary.com/2015/06/27/install-pantheon-desktop-ubuntu/

but on logging out I did not see Pantheon in the list of desktops. I logged into Unity, and found my desktop empty, with no icons (the launcher had the same icons, but the Files, System Settings and Software Center icons have all changed). The background had reverted to the default image (I was using a downloaded image). The top black menu bar was missing and in the top right corner all the icons were different. I was able to find all my applications in the Dash, and they were all working. I checked home/user/Desktop and they were all there. I tried dragging them from the Dash to the desktop, but to no avail. I tried to change the desktop background in Settings, but it was already linked to my downloaded image. I logged into GNOME, and my desktop icons weren't there either. However my downloaded image was in the background. Shortcuts like the super button and Ctrl+Alt+T weren't working in either desktop. . I logged into LXDE and everything was working fine. The desktop icons were there and my image was in the background. Shortcuts were working. I was mainly using Unity, so this is very annoying to say the least, and I need an answer soon.

1
  • When desktop items in Unity are not shown, it's usually the Nautilus daemon which has crashed or did not start. If you manually launch it (nautilus command or open the Files manager, you may close the opening window again), the icons usually reappear. It won't work if it has a different cause, but should be worth a try.
    – Byte Commander
    Feb 2, 2016 at 7:44

2 Answers 2

0

Other than suggest you to keep more atention next time and don't go around pasting commands (this is a comment in the site you mention: "This repository no longer has elementary-desktop package" and you also verify this in the PPA itself) the best you could do is remove the PPA along with any package that installed. This wont guarantee anything and please be careful with pasting commands when you don't know what they do.

To remove this PPA and the packages it installed you should first install PPA purge with this command:

sudo apt-get install ppa-purge

Following with:

sudo ppa-purge ppa:elementary-os/stable

This should downgrade any package you installed back to the official Ubuntu repository ones.

2
  • Unfortunately that did not work. Short of putting all my apps on a USB and installing Ubuntu again, is there anything else I can do? Jan 20, 2016 at 16:20
  • Why put all the programs on a USB? :) just use a seperate /home folder and make a list of the programs and sudo apt-get install package1 package2 package3 etc. Jan 20, 2016 at 16:34
0

Try this:

dconf reset -f /org/compiz
unity --reset-icon &disown

and it might work fine this way.

2
  • It's giving an error that replace doesn't exist. Jan 21, 2016 at 15:58
  • Sorry it didn't work. Jan 21, 2016 at 16:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.