6

I have a remote computer on AWS (EC2 gl2.2xlarge) with Nvidia GRID card K520 and want to remotely render 3D graphics. I use Ubuntu 14.04 - 64 bit running Unity desktop. Remote and local. For remote connection and OpenGL rendering we use VirtualGL and TurboVNC (*amd64.deb).

I properly installed VirtualGL and TurboVNC and Nvidia 352.63 drivers ( cuda 7.0, because according to this post cuda 7.5 is unstable - which was also unstable for me ).

As I understand VirtualGL uses display :0 and TurboVNC uses display :1 on remote machine.

When I connect to the remote machine and I want to run a 3D app (via vglrun ) it gives me error:

extension "GLX" missing on display ":0.0".

I don't undrestand how VirtualGL works on a remote machine with TurboVNC, how it uses the display :0 and if it's ok.

Do I need something to setup (.conf, graphic driver). I tried installing it over and over, tried serching for answer, but I didn't find a solution.

I can establish connection via TurboVNC with no problem, but vglrun gives me the mentioned erros. Can the problem be in set x.org settings ?

Thanks

1

The problem was, that there was only 1 X server running, so I only had to do sudo xinit &

after that, vglrun started to work!

EDIT:

if anyone stumbles upon the same problem, this stackoverflow answer helped me a lot: https://stackoverflow.com/questions/34805794/virtualgl-and-turbovnc-extension-glx-missing-on-display-0-0

  • the problem with this is, the actual display that my server is physically connected to , gets black. Any way to keep both things ? – harveyslash Nov 20 '16 at 16:21
  • It seems you already have an X server running on your server (otherwise you won't have anything that can turn black in the first place). It is likely that your physical display turns black since you want to start a second X server on the save GPU. Actually, you don't need a second one. Just find which DISPLAY the first X server uses and point vglrun to that display with the -display option. – zaxliu Sep 25 '17 at 8:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.