0

it's my first post to askubuntu, therefore I will try my best.

My problem is, that I bought a Thinkpad Yoga 260 and tried to install Ubuntu on it, but if I start the boot USB key and select the installation of Ubuntu, it get's stuck on a black screen.

I googled a lot and tried to add various flags to run the installation, but it ended always on a black screen. Afterwards I tried to install Mint Cinnamon and I succeeded. Therefore I thought to try out Mint and give it a try, but I discovered that the touchscreen and Wacom Pen doesn't work. After some research I found out that Mint doesn't support touchscreen.

Therefore I'm back to my problem, to install Ubuntu on my Thinkpad Yoga 260. My actual point of knowledge is that the new Skylake cpu's and gpu's are supported by the kernel 4.3 and this kernel is integrated in the 16.04 Alpha. But I don't succeed to install it.

It would be great if somebody could help me or struggles with the same problem.

Greetings, albflo

  • 2
  • I tried some things which are mentioned in this thread, but I'm still stuck on the black screen, now I try to set up fedora with gnome 3. – albflo Jan 20 '16 at 15:09
  • Parameter nomodeset didn't work? – bain Jan 20 '16 at 16:22
  • I tried various times to get to the install with nomodeset, the first try was to add it to the end of the linux line, then I added it after and another time before quiet splash . On a thread about a similar problem they said to replace quiet splash, but also this doesn't worked. At which place it would be supposed to be? I forgot to mention that when i replaced it, I got no black screen, but a screen with time stamps and various messages after it.. – albflo Jan 20 '16 at 17:40
  • 1
    Can you try the grub gfxpayload and kernel boot params from this answer – bain Jan 20 '16 at 18:02
2

There is an issue with Skylake processors and Intel pstate drivers in the Linux kernel that hangs the boot process, usually on the message "Intel_pstate: HWP enabled".

If you add "intel_pstate=no_hwp" to the GRUB boot parameters it should work. (Instructions: https://wiki.ubuntu.com/Kernel/KernelBootParameters)

However, this disables the more efficient frequency scaling capability (= longer battery times) in Skylake, so hopefully it will be solved soon.

The issue is being worked on here: https://bugzilla.kernel.org/show_bug.cgi?id=110941

  • thanks for your contribute! I solved it the same way you describe. Yes I'm also hoping that the bug will be solved soon. – albflo Mar 27 '16 at 11:56
1

To help other people, which are struggling with an equivalent issue, I will post here my solution.

Thanks to @bain I got to this thread New laptop (Skylake) cannot boot Xubuntu even with boot parameters where an equivalent problem was posted. There solution was to add some kernel flags to the boot options, therefore I tried it and got into Ubuntu Live USB with a display resolution of 640x480. To get full resolution and the final opportunity to install Ubuntu I deleted nomodeset from my flags and got full resolution. My final kernel flags for the boot option replaced quiet splash --- :

i915.preliminary_hw_support=1 nouveau.blacklist=1 edd=on nolapic pcie_aspm=force tpm_tis.interrupts=0 ---

Now I have installed Ubuntu 15.10 and upgraded to kernel 4.3, but I'm still struggling to get a GRUB menu and to boot finally into Ubuntu.

EDIT: After various tries I edit a Ubuntu live USB key to start the grub from my Ubuntu and was able to enter my Ubuntu installation. But to set up the UEFI boot menu is still a problem and I will try later to solve it. Now I try to set up my Wifi: I installed the new firmware from Intel and the driver, also I tried to add intel_pstate=no_hwp to the kernel parameters, because it was suggested in a similar thread. But it doesn't solve the problem for me.

I will add later more details of my progress.

EDIT: I tried different kernel parameters for the boot options and now I only need nolapic to be able to boot Ubuntu and i915.preliminary_hw_support=1 to enable the touchscreen and the active pen.

EDIT: I tried to install kernel 4.4, but afterwards Ubuntu showed a fatal error. Therefore I thought it could be worth to try out a daily of 16.04. To install it I needed intel_pstate=no_hwp in the kernel parameters and on 16.04 I had no issues with my wifi. The only remaining problem was that I wasn't able to enable my touchscreen and active pen, but after some days and some updates of Ubuntu it worked perfect. Now I have no system problems left and can work with my new notebook, my last thing to solve is only to enable grub on the startup.

Thanks everyone for the help!!

0

You could try the kernel command-line addition:

i915.preliminary_hw_support=1

It is my understanding that all is good with kernel 4.4, so once installed upgrade and you should be sweet.

Please let me know if this works, I just ordered a yoga 260 to replace my x201T.

source: http://www.phoronix.com/scan.php?page=news_item&px=intel-skl-prelim-support

  • Thanks for your support, but I add the line at the end of the linux kernel line like this: linux /casper/vmlinuz.efi file=/cdrom/pressed/ubuntu.seed boot=casper only-ubiquity quiet splash --- cdrom-detect/try-usb=true noprompt persistent i915.preliminary_hw_support=1 . But it doesn't work, I disabled also all settings in the Bios like Quickboot or Secureboot. Or have I missed something? – albflo Jan 20 '16 at 10:23
  • try this: linux /casper/vmlinuz.efi file=/cdrom/pressed/ubuntu.seed boot=casper only-ubiquity i915.preliminary_hw_support=1 --- cdrom-detect/try-usb=true noprompt persistent or linux /casper/vmlinuz.efi file=/cdrom/pressed/ubuntu.seed boot=casper only-ubiquity i915.preliminary_hw_support=1 nomodeset --- cdrom-detect/try-usb=true noprompt persistent – user299064 Jan 20 '16 at 17:55
  • Thanks for your help, i tried both methods but ended up to the same error : intel_pstate: HWP enabled . Afterwards I tried something from the link which @bain posted and I succeeded to install Ubuntu 15.10. I will write to my main post the solution! Thank you for everything! – albflo Jan 20 '16 at 19:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.