0

Lately I tried to (manually) update my graphic drivers on my ubuntu 14.04 . So I downloaded deb package from Amd website and install it. Unfortunetly package was allegedly corrupted so I was force to run apt-get -f and remove it . After reboot I get popout informing me that system is running in "low graphic mode" . But when i choose option to agree to one session in low graphic mode , everything is getting stuck in some kind of loop. So basically i only Have access to console login. I've tried to using xinit command but it throws error too. What should I do ?

1

How about trying this? https://help.ubuntu.com/community/BinaryDriverHowto/AMD#Manually_installing_Catalyst_13.4

Do it step by step so you know you are doing it correctly.

I have never had Linux + AMD, so this was all I could come up with. I know Nvidia blacklists the open source drivers, maybe AMD does the same?

0
1

It may be a good idea to do a clean reinstall of your OS. AMD video drivers are finnicky and require a strict procedure to install and update. If you decide to reinstall your OS entirely, you can install/update the video drivers for your AMD GPU following this process:

  1. Make sure you are using the open source divers (you can check on the aditional drivers tab, under your system configurations)

  2. Uninstall the fglrx drivers (the proprietary AMD drivers). To do this, run this command on the terminal:

    sudo apt-get purge "fglrx.*"

  3. Delete your xorg.conf:

    sudo rm /etc/X11/xorg.conf

  4. Redownload and install xorg completely:

    sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:amd64 libgl1-mesa-dri:amd64

  5. Configure xorg (if this command gives you an error, don't worry about it. This one is more just to be safe than for anything else):

    sudo dpkg-reconfigure xserver-xorg

  6. Reboot your computer.

I do this everytime I need to install a new AMD driver version. It helps to avoid errors. When you boot again, you should be using the open source drivers by default. After this, you can proceed to download and install the AMD drivers:

  1. Go to AMD's website (www.amd.com) and on the tab "Drivers and Support" click on the option "Drivers + Download Center".

  2. Once the page loads, look for the "Latest AMD Drivers and Software" section and choose the apropriate sub-section for your GPU. For example, I have an R9 270X, so I would choose "Radeon™ R9 200, R7 200, HD 8500 - HD 8900, and HD 7700 – HD 7900 Series". On the apropriate sub-section, click on the link that says "RHEL / Ubuntu / Linux".

  3. Another page will load and here again you will have to look for the apropriate section for you. On my example, I'm using Ubuntu 14.04 64bit and an R9 270X, so I would choose the "Ubuntu 14.04.2 64bit" link, under "Radeon™ R9 200, R7 200, HD 7000, HD 6000, and HD 5000 Series".

  4. On the next page, download all the packages compatible with your system. On my case, I would download all the packages marked with "14.04". On the Crimson 15.12, there are 4 .deb packages to download (Video Driver for Graphics Accelerators; Minimal Video Driver for Graphics Accelerators (Non-X Support); Video Driver for Graphics Accelerators Devel Files (OGL, OCL); Radeon Setting)

  5. After you download all the packages you need, put them in a folder exclusive for them. Open this folder in the terminal and issue the comand:

    sudo dpkg -i *.deb

This command will install all the .deb files located in that folder atuomatically for you. If the install fails, read the output on the terminal. It probably needs some dependent packages to be installed. To install these packages, simply read from the terminal which ones they are and use apt-get to install them. For example, in my system I had to do:

sudo apt-get install lib32gccl libc6-i386 dkms

After you installed any dependecies, run

sudo dpkg -i *.deb 

again and the instalation should complete.

  1. After the instalation completes, issue on the terminal:

    sudo aticonfig --initial

and reboot your computer. When it comes back, you should be using the proprietary AMD driver :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.