1

My company uses WPA2 Enterprise encryption. I entered everything like so. I have seen this issue a couple of times on this forum, but I have a slightly different question. We connect to this WIFI for dozens of devices. Android, MacOS and iPhone. Why would the Linux setup be different and require configuration.

Typically, we would hit the WIFI and the on the first time, a page(with my browser) will come up for me to confirm the certificate. But that isn't working on Linux. I also travel to various hotels and there is a prompt after initial connection, will I have the same issue?

Security : WPA & WPA2 Enterprise
Authentication : Protected EAP (PEAP)
CA certificate I downloaded from the MAC machine and copied the cer file to Ubuntu
PEAP version : Automatic
Inner authentication : MSCHAPv2
Device: HP Stream 11

I am using Ubuntu 15.10

Also, other documentation recommends, setting 'system-ca-certs=false' but this entry is not defined in the file. I changed the setting but it still does not change the connection.

When I try to connect, the WIFI indicator seems like it is working and then eventually I get a prompt for username and password. I attempt to connect but the prompt returns again. I cannot connect to the Internet.

It is possible that the certificate information is not correct. Is it possible to have Ubuntu prompt a browser for me to continue like it does on the Mac? I exported the certificate from the Mac (Keychain export) and then copied that file to the Ubuntu machine.

Is there other software that I could use? Do I need wpa_supplicant? I hate mucking with my wifi network configuration settings. When I on other devices (mac) I never had to.

0
2

So I had the same problem and just got it working on Ubuntu 15.10. The solution requires the following steps

  1. Use the Network-Manager to add the SSID (Screen shot of setup). Make sure authenticated is set to PEAP and inner authentication is MSCHAPv2. Make sure to select with your login and password and watch it fail.
  2. Hit cancel
  3. Next, navigate to /etc/NetworkManager/system-connections
  4. Now edit the file matching your network SSID.
  5. Delete the line that says "phase2-altsubject-matches=" in the [801-1x] section.
  6. Save and select the SSID in Network-Manager again. Connects perfectly.

I'm not sure what this line is for, but removing it works. One think to watch out for though, any time you use the gui to edit the connection, the line returns and again has to be removed.

Note the cert shouldn't be necessary, unless IT gave you the cert to use.

Just upgraded to 16.04 and the same bug remains. Removing the line still works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.