4

My system has poppler-utils v0.24.5. From the official site I found that the latest version is 0.40.0.

I tried to update it using following command

sudo apt-get install --only-upgrade poppler-utils

but it doesn't upgrade and show following message.

poppler-utils is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 14 not upgraded.

Can anybody please help me to upgrade to latest version?

7

This is because Ubuntu focuses on stability, not bleeding edge packages, this means that the software in the repositories can be outdated and you must build it from source yourself.

First remove the current installed version

sudo apt-get purge poppler-utils

Install the required build tools

sudo apt-get install build-essential checkinstall

Run these commands to build and install

wget --directory-prefix=~ poppler.freedesktop.org/poppler-0.40.0.tar.xz
tar -xvzf ~/poppler-0.40.0.tar.xz
cd ~/poppler-0.40.0
./configure
make
sudo checkinstall

Now poppler-0.40.0 is installed on your computer.

  • 2
    Relevant: askubuntu.com/a/705380/367165 – A.B. Jan 19 '16 at 14:43
  • @markkirby : Another useful answer from you ! :) – cl-netbox Jan 24 '16 at 11:46
  • 2
    If you run the wget command from your home directory, you may end up with a new directory /home/username/\~ . I'm not sure what caused this though. It's also not gzip compression, so the -z seems unnecessary. – Annan Jul 20 '16 at 16:04
  • I think its 'build-essential' rather than 'build-essentials' in the install line, right? – ohnoplus Apr 2 '17 at 4:12
  • @ohnoplus Yes it should, well spotted. – Mark Kirby Apr 6 '17 at 12:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.