I installed Ubuntu 14.04 with dualboot. But i have problem with microphone noise. I can not find any noise reduction in Ubuntu.

Sound quality is for me quite important, because i am talking with friends on TeamSpeak, recording videos on youtube and doing livestreams.

I have microphone in headset, and i never had any problem with it in Windows.

I tried alsamixer and PulseAudio Volume Control, but it does not help, because it only lowered my volume, but noise is still here.

Please do not post here applications like audacity, because i need realtime reduction, because livestreams and talking on teamspeak.

PC: Desktop

Sound card: Realtek® ALC892

  • Try to modify settings into pavucontrol Jan 19, 2016 at 11:53
  • 1
    I tried PulseAudio Volume Control, but it is same like alsa mixer, noise is quieter, but my voise is quieter too, so in skype or teamspeak people can not hear me.
    – tomsk
    Jan 19, 2016 at 12:32

2 Answers 2


At 2020, mic noise is still an issue. I got some luck with the following setting though.

Add at the end of the /etc/pulse/default.pa file:

set-default-source echoCancel_source
set-default-sink echoCancel_sink
load-module module-echo-cancel use_master_format=1 aec_method=webrtc aec_args="noise_suppression=1" source_name=echoCancel_source sink_name=echoCancel_sink
set-default-source echoCancel_source
set-default-sink echoCancel_sink

Then restart Pulse (and after each time you restart your desktop session):

pulseaudio -k && pulseaudio --start

The mic volume can't be pushed above 50%, the noise comes back! 40 % is the best catch I found for no noise at all.


Try reducing the input volume in the sound settings. By normal the volume shouldn't be that high. Mine is shown in the picture.

Sound settings in Ubunut

  • Doesn't help, if it is low as your, nobody hear me (skype, teamspeak etc..)
    – tomsk
    Jan 19, 2016 at 12:38
  • Well, I have this setting and I can talk to others on Skype even when I'm not that close to the laptop.
    – Mrchacha
    Jan 19, 2016 at 12:57
  • 1
    Yes, but you have different microphone, i am silent when talking. I have SteelSeries Siberia v2 Headset and in Windows i have no problem with it, because in Windows is magic button noise suppression which works perfeclty even if i have 100% volume + 20db boost
    – tomsk
    Jan 19, 2016 at 13:31
  • 1
    I love saying this: 'Worked like a charm!' Jul 22, 2017 at 12:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.