1

So I am trying to install Atom on my Chromebook running Xubuntu 14.04 (64 bit). I downloaded the .deb from atom.io, but when I ran sudo dpkg -i atom-amd64.deb, it returned:

Selecting previously unselected package atom.   
(Reading database ... 138331 files and directories currently installed.)   
Preparing to unpack atom-amd64.deb ...  
Unpacking atom (1.4.0) ...  
dpkg: dependency problems prevent configuration of atom:  
 atom depends on gvfs-bin; however:  
  Package gvfs-bin is not installed.   

dpkg: error processing package atom (--install):  
 dependency problems - leaving unconfigured  
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...    
Processing triggers for mime-support (3.54ubuntu1.1) ...      
Errors were encountered while processing:   
 atom

After this, I did sudo apt-get install gvfs-bin, which returned:

Reading package lists... Done       
Building dependency tree             
Reading state information... Done       
You might want to run 'apt-get -f install' to correct these:       
The following packages have unmet dependencies:         
 gvfs-bin : Depends: gvfs-common (= 1.20.1-1ubuntu1) but 1.20.3-0ubuntu1.1      is to be installed          
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

But running sudo apt-get -f install said all dependencies were correct and asked me if I wanted to remove Atom while running sudo apt-get install gfvs-common returned that it was already installed to the latest version.

I am also having trouble installing clang-3.5, where it returned that it needs some libs.

Edit -- I've switched to GalliumOS on my Chromebook, which is natively meant to run on Chromebooks and it's worked much better. I'll leave this question up in case if anyone else needs it and thanks for all the responses.

  • 1
    try running dpkg --configure -a; sudo apt-get install gvfs-bin gvfs-common – cat Jan 19 '16 at 3:22
  • What's the output of apt-cache policy gvfs-bin gvfs-common? – David Foerster Sep 27 '16 at 8:23
0
 sudo apt-get autoclean

remove sources.list file.and create new sources.list...

sudo rm /etc/apt/sources.list 

Then, type in

sudo software-properties-gtk 

enter image description here This will open software-properties-gtk and a newsources.list will be created automatically.

Then change the server to US or to any other server of your choice. You must enable repositories from the new dialog in order to create new sources.list.

Tick all the boxes then click on Revert then click close.

Need to restore default repositories

 sudo apt-get update && sudo apt-get dist-upgrade -y

(it is good practice to backup this file before installing to recover if such things happen)

Now install anything! I suggest to install gdebi and download deb file of atom from their site... gdebi will install .deb file of atom with some internet:)

| improve this answer | |
  • If software-properties-gtk is not installed..install it after this process using sudo apt-get install software-properties-gtk – minigeek Sep 27 '16 at 3:50
0

Try installing from the repository using the following method, works fine for me:

sudo add-apt-repository ppa:webupd8team/atom

sudo apt-get update

sudo apt-get install atom
| improve this answer | |
0

Run:

sudo apt-get install git libnotify4 gvfs-bin

If that doesn't work, run:

sudo apt-get install -f

That's what worked for me.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.