1

Situation:

After installing Linux Mint 17.3 alongside Windows 10, I lost the ability to boot into Windows. Here is my partition table:

Partition Table

  • /dev/sda2 is the Windows 10 C: partition (that is mounted for some reason)
  • My linux partitions are all logical, part of the /dev/sda1 extended partition

When I boot the machine, grub only shows the Linux boot, so I can't boot into Windows.

What I've tried:

  • I booted into the Linux Live USB, install Boot Repair and ran the Recommended option.
  • I Ran the advanced option of Boot Repair, setting the boot partition to Windows. Didn't change anything.
  • I tried booting in Linux and running sudo update-grub. Got the following result:

    Generating grub configuration file ...
    Found linux image: /boot/vmlinuz-3.19.0-32-generic
    Found initrd image: /boot/initrd.img-3.19.0-32-generic
    Found memtest86+ image: /memtest86+.elf
    Found memtest86+ image: /memtest86+.bin
      No volume groups found
    done
    
  • Booted into a Windows 8 Recovery Disk (I don't have the Windows 10 one), and ran bootrec.exe /fixmbr in the Command Line. As a result, I got the BOOTMGR is missing message.

I managed to get Linux booting again from the Linux Live USB's Boot Repair tool.

Question

Given the partition table above, how can I get Grub to show Linux AND Windows 10 to show, so I can boot into Windows as well?

  • 1
    The Linux mint installer seems to have to deleted the 100MB boot partition for Windows. Without that, you cannot boot. It seems to have deleted it to allow for the creation of the extended partition. – QwertyChouskie Jan 19 '16 at 0:51
  • 2
    Linux Mint is off-topic on Ask Ubuntu. Unless you have Ubuntu on that machine (and this problem actually applies to it), you'll have to transfer this question over to Unix & Linux. (BTW, though, it sounds like the Windows boot manager is just gone.) – TheWanderer Jan 19 '16 at 0:54
  • @user4901968 Err... Actually I think I deleted it myself, since Windows had 4 Primary partitions already and I needed one Extended. Is there a way to recreate that 100MB boot partition? – sargas Jan 19 '16 at 0:58
  • @Zacharee1 How do I transfer? Also, thanks for the insight. As I commented here, I think I was stupid enough to delete it myself. I think I learned the lesson: Don't go around deleting partitions you didn't create. – sargas Jan 19 '16 at 1:01
  • 1
    Definitely don't do that :p. I think the only way to recreate the EFI partition is to reinstall Windows, unfortunately. To transfer, you can just copy the content (do it from the edit field to preserve formatting), delete it here, then paste it into a new question on Unix & Linux. I think it's pretty much resolved though. – TheWanderer Jan 19 '16 at 1:03
0

Windows boot loader manager is deleted - at least this is how it looks like. Better to use the same recovery manager recovery disk(Windows 8) and then recover the Windows O/S. Once that is done - then install any flavor or Linux(i prefer and recommend Ubuntu). I see you are talking about Windows 10. Right now Windows 10 free upgrade is going on also - so you may be do that and then start installing linux. Make sure that you create a recover USB/disk for Windows 10 in case you are going to install Linux(ubuntu or any other favor). I suggest Windows disk management utilities to do the partition from Windows for Linux. When installing Linux - go thru each step carefully(use automatic partition in case of ubuntu desktop 14.0.4 or 15.10) which creates a ext4 partition mounted at '/' and a swap partition. Live USB also had a feature to try ubuntu rather than installing so that you can play with until you are comfortable and would like to install it. Hope this helps.

| improve this answer | |
1

Seems like you've done everything but the most basic: update GRUB. Boot into Ubuntu and run, in a terminal:

sudo update-grub

GRUB should recognize Windows.

| improve this answer | |
  • I forgot to mention that I did run it (also, Boot Repair runs it for you). I got a No volume groups found when I ran it manually. I'm going to update my question. – sargas Jan 19 '16 at 0:48
  • Please do the following: * Boot your computer. When you see the GRUB menu, press 'c'. You'll be dropped in a GRUB command line. Issue the following commands: set root=(hd0,msdos2) chainloader +1 boot If you get any error, run everything again replacing msdos with gpt in the first commands . That should boot Windows. If it works let me know it. – Eduardo Cola Jan 19 '16 at 0:57
1

It seems that you have deleted your windows boot-loader/manager!

Ubuntu & Mint both identify Windows as Windows &/or System When correctly installed. This question is probably better off in Super User. Maybe somthing like... How to fix boot manager without harming Linux?

enter image description here

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.