0

I've an Asus K52JT and a problem with Elantech Touchpad...it lag horrendously!!!

simone@atari:~$ lsb_release -r
Release:    15.10

simone@atari:~$ uname -r
4.2.0-23-generic

simone@atari:~$ xinput --list
⎡       Virtual core pointer                        id=2    [master     pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                  id=12   [slave    pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
↳ Power Button                              id=6    [slave  keyboard (3)]
↳ Video Bus                                 id=7    [slave  keyboard (3)]
↳ Sleep Button                              id=8    [slave  keyboard (3)]
↳ USB 2.0 Camera                            id=9    [slave  keyboard (3)]
↳ Asus Laptop extra buttons                 id=10   [slave  keyboard (3)]
↳ AT Translated Set 2 keyboard              id=11   [slave  keyboard (3)]

I tried several solution, the last one was updating the BIOS (K52JTAS.206).

Nothing work! Any advices are welcome.

  • I have the same problem on my Lenovo u530 touch. Sometimes it is driving me nuts, but I guess one can accustom to many things :D I can also confirm this issue on recent Arch builds as well as Ubuntu using MIR and now for the fun part: Mac OS X. Only Windows seems to have a proper driver. – lucaelin Apr 11 '16 at 22:40
0

I am having the same problem, and still have no solution. However, I think a way to solve it is bu modifying the xinput settings.

Reasoning: - In my Lenovo, the trackpad works perfectly and so do external wireless mouse. And the touchpad does work without delay in some instances, so it should be capable - Just from experience the xinput settings in Linux systems don't come as refined as they could be. Sadly.

What I'm doing right now is having xinput list and in another window a xinput list and try to make sure the settings are similar. Will update if I find the right config settings.

Do: xinput set-prop <# of touchpad> "Device Accel Profile" 0

That did it for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.