0

I love tiling window managers. I tried i3wm the other day and loved it. However, I spent all day trying to get my multimedia keys to work. They never did. GNOME and Unity both recognize the key presses and perform the appropriate action.

I am using a laptop where I have to hit an FN key and then the key that I want. There are really only four keys that I care about:

FN + F9 = touchpad toggle

FN + F10 = mute sound

FN + F11 = lower volume

FN + F12 = increase volume

I want a tiling windows manager that has all of these keys working out of the box. I am done trying to mess around with config files. I have tried to get them to work and they continue to give me headaches.

10
  • Unity and Gnome have unity-settings-daemon and gnome-settings-daemon applications, which launch on each login to those environments. Easiest solutions for you would probably to launch one of those daemons manually once you login to your tiling window manager Jan 18 '16 at 17:52
  • How would that work?
    – Avi Caspe
    Jan 18 '16 at 17:57
  • Well, login to i3wm , open terminal , and run gnome-settings-daemon , then check your keys. Jan 18 '16 at 18:02
  • Do I need to keep GNOME installed? I got rid of unity a while ago.
    – Avi Caspe
    Jan 18 '16 at 18:17
  • I'd say keep it, you never know when you may want to switch back to Gnome. I personally keep multiple environments in case something breaks. But you can remove gnome-shell package and check with apt-cache policy gnome-settings-daemon. If it says it's still installed - good, if not - you can run sudo apt-get install gnome-settings-daemon . Also let me know if this helps and I'll post it as a proper answer. Comments are not for posting solutions Jan 18 '16 at 18:53
1

I managed to get it working. I just appended the following to my i3 Config file:

# Multimedia Keys
#increase sound volume
bindsym XF86AudioRaiseVolume exec --no-startup-id amixer -D pulse sset Master 5%+
#decrease sound volume
bindsym XF86AudioLowerVolume exec --no-startup-id amixer -D pulse sset Master 5%-
# mute sound
bindsym XF86AudioMute exec --no-startup-id pactl set-sink-mute 1 toggle

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.