I'm having some troubles setting up my network connection using the Bridged Adapter configuration. I'm just starting with Linux and even if I was going through different forum discussions on the web, I'm still not able to make it work. NAT is working perfectly and I'm able to access Internet, while with Bridged Adapter the network result unreachable, altough I need it for the application I have in mind.

My setup is the following:

VirtualBox 5, Host: Windows 10, Guest: Ubuntu 14.04 LTS

Here you could see in details my configuration

VirtualBox Network Config Beside the RealTek, I could use also: Qualcomm Atheros AR946x Wireless Network Adapter. However the problem remain the same, since it seems I have no network working.

This if the ifconfig command:

    giulio@giulio-VirtualBox:~$ ifconfig
    eth0      Link encap:Ethernet  HWaddr 08:00:27:f5:87:2f  
              inet6 addr: fe80::a00:27ff:fef5:872f/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:88 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:24737 (24.7 KB)

    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:161 errors:0 dropped:0 overruns:0 frame:0
              TX packets:161 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:11409 (11.4 KB)  TX bytes:11409 (11.4 KB)

While /etc/network/interface looks like this:

      # interfaces(5) file used by ifup(8) and ifdown(8)
      auto lo
      iface lo inet loopback

Here it is a screenshot of the overall network settings. For the IPv4 settings I'm using AUtomatic (DHCP), while for IPv6 I've set "ignore".

I hope somebody could have a look and help me out, thank you! Giulio

  • Having the same problem. Did you manage to fix this? – Tony Tannous Jun 11 at 8:11

I have tried to make it work with bridged and after a lot of troubleshooting, it worked.

The primary issue was that my guest OS was sending packets with different MAC address compared to my host OS.

Thus the traffic was getting dropped at wifi gateway.

The solution was to change the MAC address in guest OS and have same MAC for guest as well as host OS.

Steps:

  1. Power off the VM

  2. Go to Settings->Network->Advanced and remove the mac address.

  3. Check the mac address of host machine (ifconfig -a or ipconfig /all) and update the same in the option in step 2.

  4. Save the settings and start the VM, it should work and internet should be reachable :)

New contributor
sushil sharma is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

First of all: Bridged config does not work with wi-fi.

So you can't bridge the Qualcomm Atheros AR946x to your VMs, but you can use the Realtek adapter, I can see that you're only showing the Ubuntu config and the VM config, but the matter may be with Windows.

I suggest you find how your Windows network is configured to make it work.

Maybe this can help you find the problem: https://stackoverflow.com/questions/31922055/bridged-networking-not-working-in-virtualbox-under-windows-10

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.