Today I installed an Nvidia GT440 on my computer, changing the one that existed there, an Nvidia 9500GT. After changing it I started getting a problem where the screen just went black when loading the lightdm login screen (Where I punt my user and password). The thing is, if I disconnect the VGA cable and connect it again I get to see the lightdm greeter and everything works perfect.

The problem is that I have to connect/disconnect every time I reboot the PC.

I tried installing the 285.xx drivers. Same problem. I removed the Nvidia drivers installed with Jockey, rebooted, same problem. I install the current 280.xx again, same problem.

After all that I installed a fresh install of Ubuntu, selected to install the Nvidia drivers while installing it from the livecd. After booting the same problem appeared.

Dmesg does not say anything wrong about it. Same goes for the log from Jockey.

What else should I check or what to do to solve it.

Just to clarify, this does not happen BEFORE the lightdm greeter appears. Am guessing before the actual use of the video card with X starts with all the 2D/3D stuff that is used in ligthdm and unity. I can use any tty and even see the Ubuntu logo when starting.

UPDATE: When I open a game in fullscreen the problem appears again. I have to unplug the monitor cable and plug it back in to see the game. Then when I quit the game I have to do it again to see the desktop.

UPDATE 2: Today I bought a HDMI cable, connected the video card to the TV am testing it with and it actually did log in correctly without any black screen but it shows the resolution a little over the actual size of the screen. So I see only half of the launcher since the left side of it is hidden outside of the real resolution and the top bar is beyond the resolution. So the black screen is related to the VGA connection.

UPDATE 3 - After installing 12.04 and updating or installing 12.10, black screen problems are gone.

  • I have a similar problem with Nvidia GT220 and driver 285.05.09. When I change of user it works well, but when I close that session to resume the another open session, it shows a black screen for quite some time until finally it retrieves the session. I think lightdm is very buggy to use normally. I change to gdm again. Nov 12, 2011 at 12:49
  • How long did you have to wait. I have not actually waited yet for this. Just 10 minutes tops. Nov 12, 2011 at 14:31

2 Answers 2


This has since been solved by installing and updating the Nvidia driver to 290.xx or greater.

To do this follow this steps:

The launchpad https://launchpad.net/~ubuntu-x-swat/+archive/x-updates has the latest Nvidia Drivers (And Ati, And Intel, And...)

In a terminal execute: sudo add-apt-repository ppa:ubuntu-x-swat/x-updates

Update your repositories either by clicking on the "Check" button in the Update Manager or running in a terminal sudo apt-get update

The Nvidia driver version 290.xx should appear available. Install it, reboot, done.

This solved the black screen problem using a VGA cable with a TV (Might also solve other problems mentioned in the changelog)

NOTE - This did not solve the problem that some users are having that the resolution is outside of the border of the TV. As Oli mentions in this question HDTV resolution issue the overscan problem is what I am talking here. Although in my case there is no way to configure or tune this with the TV (My case Soneview 32')

More information in How do I install the Nvidia drivers?


It turned out in my case that the selected Mode (size of screen / refresh rate) was not accepted by my LCD screen.

So in /etc/X11/xorg.conf, I added the following line in the Device section which you could also set in the 'Screen' section:

Option "metamodes" "800x600"

After doing

sudo service lightdm restart

The display was no longer black and I could use the Nvidia configuration tool.

After trying some options, I was able to use the full resolution by selecting a low refresh rate. After writing the settings, the following line appeared in xorg.conf:

Option "metamodes" "1280x1024_60 +0+0"

in Section Screen (the other option was removed). The new line says to use resolution 1280x1024 with refresh rate 60.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .