1

Using xfce4-terminal, if I type:

PS1="\[\e]0;\w\a\]> "

I get as expected > as my prompt, and the current working directory shows up in the window title. But instead of just being ~/Documents, the window's title is Terminal - ~/Documents.

Screenshot of xfce4-terminal with <code>Terminal - ~/Documents</code> in the window's title

How can completely customize xfce4-terminal's window title, and get rid of the Terminal - part?

3

In XFCE Terminal's Preferences, are options to control the title:

enter image description here

Change the Dynamically-set title to Replaces initial title.

0

Just disable the border of the terminal on the general tab of the terminal preference or add --hide-borders option on terminal as following:

xfce4-terminal --disable-borders

If you want to remove all decorations of xfce4 terminal like rxvt style

xfce4-terminal --hide-menubar --hide-borders --hide-toolbar

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.