3

Ubuntu 12.04 has two libboost-dev packages. The default is 1.46, but there is also a 1.48. I have updated libboost-all-dev to 1.48 without any errors.

enter image description here

I was expecting that all previous links to boost 1.46 be replaced by the newer version. But they are still in place:

enter image description here

One of my libraries needs version 1.48. It looks into /usr/lib but since the symbolic links are all referring to the old boost, gives me an error. There are so many symbolic links. Is there any way to update them all? Is there any better solution since changing the links might break some other libraries that are relying on the older version of boost.

migrated from stackoverflow.com Jan 17 '16 at 19:34

This question came from our site for professional and enthusiast programmers.

  • Have you checked /usr/lib/x86_64-linux-gnu (or i386-linux-gnu)? – J.J. Hakala Jan 16 '16 at 23:04
  • Could you edit your question to add the output of dpkg -l | grep boost so we can see the versions of all your Boost packages? Please paste it as text and not as a screenshot. – fkraiem Jan 17 '16 at 19:44
3

This should be on [AskUbuntu.SE] or [SU] likely.

Anyways, to see what gets linked, do a ldd on your program

ldd a.out

To see where the libraries belonging to a package ended up:

dpkg --listfiles libboost-filesystem1.48.0

To find out which package owns the file you see:

dpkg --search /usr/lib/x86_64-linux-gnu/libboost_filesystem.so.1.48.0

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.