1

I'm quite new to this, but in the past few weeks I've been able to install Ubuntu 14.04.1 LTS on a Ventura USB hard disk (240 Gb), and after a lot of issues (getting Citrix Receiver, Adobe flash, etc. up and running) I'm now perfectly happy with my system thanks to this great community!

I've setup my Bios to look first for USB disks and when I boot I get this nice purple screen with Ubuntu on top and the fourth option is booting from W10. Everything works as I want it to.

And now, because I was so happy with my installation, I thought to clone my USB hard disk so I would have a copy in case....
Therefore I made an image of my Ubuntu drive with Macrium Reflect under W10 and restored the image on a new USB hard drive (MyPassport 500Gb).

On booting from this new HD I simply get a blinking cursor and nothing else...

Then I tried to do a disk copy with the Seagate Disk Wizard. Same result....

I spent hours to find out how I could clone my Ubuntu disk so that the result disk would be bootable and just work, but to no avail.

Appreciate your help very much!

Thanks, Dirk

  • I would try dd if=/dev/sdx of=/dev/sdy where /dev/sdx is your existing ubuntu USB drive and /dev/sdy is the USB drive you want the cloned copy on. This will make a bit-by-bit copy on sdx onto sdy, nuking sdy in the process, so you want to get your input and your output files straight ot you will be one sad puppy! Plan on leaving it overnight, as this could take some time, and doesn't show you progress or time remaining. – Marc Jan 16 '16 at 23:57
  • You probably need to re-install grub on the new hard drive because the drive layout has changed. Follow the instructions in this answer to run grub-install. – bain Jan 17 '16 at 15:15
  • Macrium doesn't work great with Linux(or ext4) try clonezilla! – FreeSoftwareServers Jan 27 '16 at 6:04
0

First, I suppose your external drive is formatted as ext4. If it's not, bang your head in a wall and say 25 prayers to our lord Torvalds (just kidding by the way). And format it as ext4. And clone Ubuntu again. When you're done, let's continue.

There may be more things to do, but the first, essential step is modifying your /etc/fstab file. This file is responsible for automounting some partitions (including the root partition) and it uses these partitions' UUIDs by default (UUIDs are exclusive identities given to some devices). Since UUIDs are unique, you'll have to change fstab. Plug in your external drive. Boot your computer into Ubuntu

Open a terminal and run sudo blkid /dev/sdXY. Replace sdXY with the name of your external drive (you should know it to this point, and assuming it only has one partition the Y number will be 1). The output will tell you its UUID, take note of it. Don't miss a single number/letter! Run:

sudo mount /dev/sdXY /mnt

Now run sudo nano /mnt/etc/fstab. Find the line that has something like UUID=xxxxxx / ext4 defaults and replace xxxxxx with the UUID you got just before. Hit Ctrl+O then Enter to save the file and Ctrl+X to exit. You should now be able to boot your external drive! Congrats!

  • dd will copy the file system, all partitions and UUIDs, leaving him with an identical bootable copy of his original bootable USB drive in a single command. The downside is (1) it's likely to be slower and (2) he'll have duplicate UUIDs all over the place, so working with the original and the duplicate plugged in at the same time might be problematic. For reference: wiki.archlinux.org/index.php/disk_cloning – Marc Jan 17 '16 at 2:10
  • Well, he probably 1)didn't use dd or 2) is using a non-ext4-formatted partition. – Eduardo Cola Jan 17 '16 at 2:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.