1

So, recently, I had a 40 GB partition on my computer that I didn't use. I wanted to install Linux on it, however, I ran into problems trying to install Fedora, Arch, and Mint. Ubuntu seemed to be the only one that worked. After I installed it however, and rebooted, GRUB could not recognize Windows 8.1. I've tried boot-repair, updating GRUB, reinstalling GRUB, etc. but nothing seems to work for me. I can access the disk perfectly fine, and with boot-repair, I get a message like this:

"SFS detected. You may want to retry after converting Windows dynamic partitioning (SFS partitions) to a basic disk. This can be performed via tools such as TestDisk or EASEUS-Partition-Master / MiniTool-Partition-Wizard. EFI detected. You may want to retry after activating the [Separate /boot/efi partition:] option. Do you want to continue?"

The thing is, my C: drive is not a dynamic disk whatsoever (Last time I checked was yesterday in disk management), and the only dynamic disk I have is a 1 TB drive. This is the pastebin link that boot-repair gave me:

http://paste.ubuntu.com/14535046/

Any suggestions would be really helpful, as this is beginning to worry me. Thanks. ;-;

  • You have three drives shown, one MBR, one gpt & one SFS - Windows proprietary, dynamic partitions somewhat like LVM in Linux. Windows only boots from MBR(msdos) with BIOS, Windows only boots from gpt partitioned drives with UEFI. Ubuntu can boot either UEFI or BIOS from gpt. I think you need to undo the SFS, but that requires Windows tools and decide if you want UEFI or BIOS. Make sure Windows 8's fast start up is off, as that probably is why it is not mountable, but unless booting in same mode as Ubuntu will not be in grub. – oldfred Jan 16 '16 at 21:42
  • The problem is, I can't boot into Windows 8.1 at all and I don't believe fast boot was on. After rebooting a couple of times, the drives can be accessed, including the one dynamic drive I had. – Crusoe Jan 16 '16 at 21:45
  • If Windows is in BIOS boot mode on sda, then you need Ubuntu in BIOS boot mode on sdb. And you can leave the efi partition, but need to add a 1 or 2MB unformatted partition with the bios_grub flag. Then use Boot-Repair to do a total uninstall/reinstall of grub, so you have grub-pc for BIOS boot. Make sure to install grub2's boot loader to sdb, and keep Windows boot loader on sda. Do not run the auto fix as that installs grub to all drives. – oldfred Jan 16 '16 at 21:51
  • I have made a 1MB unformatted partition, however, there is no bios_grub flag. The flag seems to only be available to fat32 and possibly some other formats. – Crusoe Jan 16 '16 at 22:01
  • The bios_grub must be an unformatted partition. The FAT32 for the ESP - efi system partition must also have boot flag. You can have both on gpt partitioned drive, but only one per device or drive. With gparted you can right click and choose bios_grub. Or with gdisk choose ef02 for bios_grub or ef00 for ESP. – oldfred Jan 17 '16 at 2:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.