4

i'm running ubuntu 15.04, nvidia card 970gtx, drivers installed manually using nvidias script. i have fake raid 0 to dual boot windows 7 and ubuntu. i also have 4 drives using mdadm for raid 5. everything was wonderful until..

one day i was fiddling around with the powerstrip my computer is connected to when i accidentally flicked it off. the computer was running at the time. so i turned it back on and all i got was the grub prompt...

from there i tried a bunch of stuff to fix up grub to get back the option to boot ubuntu but nothing worked. so i made a live usb and booted that (efi mode). i could without issue mount the windows partition but the ubuntu partition was borked. so i cracked open gparted. it said something was wrong with my ubuntu partition so i right clicked it and told it to repair it (cant remember what the right click menu said). after that, i could mount the partition. so i happily restarted.

it tried to boot ubuntu, woohoo! but every time it says, "low graphics mode" blah blah. so i switched over to run level 3. fine i said, ive seen this a million times before, ill just reinstall the nvidia drivers and be on my way. killed the procs showing the low graphics warning. installed tthe nvidia drivers. restarted, same thing. tried many times.

again in run level 3 after some googling i found that i can mess with lightdm using systemd. so i issue systemctl restart lightdm.service and what do you know graphical login comes up and it all works.

and that is where i am, i have to manually start lightdm with systemctl. i tried dpkg-reconfigure xserver-xorg i tried puring lightdm and reinstalling it. its always the same outcome with low graphics mode.

currently i am looking at the output of systemctl status lightdm.service:

● lightdm.service - Light Display Manager
   Loaded: loaded (/lib/systemd/system/lightdm.service; enabled; vendor preset: enabled)
  Drop-In: /lib/systemd/system/display-manager.service.d
           └─xdiagnose.conf
   Active: failed (Result: start-limit) since Sat 2016-01-16 13:39:54 EST; 32s ago
     Docs: man:lightdm(1)
  Process: 1573 ExecStart=/usr/sbin/lightdm (code=exited, status=1/FAILURE)
  Process: 1569 ExecStartPre=/bin/sh -c [ "$(basename $(cat /etc/X11/default-display-manager 2>/dev/null))" = "lightdm" ] (code=exited, status=0/SUCCESS)
 Main PID: 1573 (code=exited, status=1/FAILURE)

Jan 16 13:39:54 GA-H97N-WIFI systemd[1]: lightdm.service failed.
Jan 16 13:39:54 GA-H97N-WIFI systemd[1]: lightdm.service holdoff time over, scheduling restart.
Jan 16 13:39:54 GA-H97N-WIFI systemd[1]: start request repeated too quickly for lightdm.service
Jan 16 13:39:54 GA-H97N-WIFI systemd[1]: Failed to start Light Display Manager.
Jan 16 13:39:54 GA-H97N-WIFI systemd[1]: Unit lightdm.service entered failed state.
Jan 16 13:39:54 GA-H97N-WIFI systemd[1]: Triggering OnFailure= dependencies of lightdm.service.
Jan 16 13:39:54 GA-H97N-WIFI systemd[1]: lightdm.service failed.

i saw another answer that said something was wrong with /var/lib/lightdm but mine is there and intact.. so not sure..

4

so in the end this had nothing to do with drivers. it turned out to be all about lightdm and the greeter session. somehow or another the gnome-session package was either messed up or not installed. what clued me in was the debug output of /usr/sbin/lightdm -d which complained that failed to find session configuration default and failed to create greeter session.

this lead me to: http://ubuntuforums.org/showthread.php?t=2226247

which suggested:

sudo apt-get install --reinstall gnome-session ubuntu-desktop

and it worked like a charm!

1

sudo systemctl enable lightdm should work (at least it does in runlevel 5). Try removing the nvidia drivers and use the nouveau ones to start Ubuntu and install proprietary drivers through "Additional software" (seriously, never install those with .run packages. Always use Ubuntu ways).

  • Did systemctl enable to no effect. Removed Nvidia drivers and installed Nvidia current. Couldn't get in at all. Removed those put back Nvidia run script drivers and now I can't get lightdm to start at all. – Kevin Kreiser Jan 16 '16 at 20:44
  • Can't you just remove any proprietary drivers and use the default ones for a bit? Even until we can find a solution for the problem? – Eduardo Cola Jan 16 '16 at 21:19
  • Typing on smart phone so ignore poor formatting... I Uninstalled the proprietary ones and I cant get to the gui login. What's the easiest way to get default xorg.conf setting's dpkgreconf xsreverorg? – Kevin Kreiser Jan 17 '16 at 2:16
  • Copied I failsafe xorg.conf after Uninstalled Nvidia drivers. Now I don't even get the low graphics warning just the loading dots of splash screen forever – Kevin Kreiser Jan 17 '16 at 2:21
  • Ah I have some more info. To google... starting lightdm with debug option says failed to find session configuration default failed to create greeter session – Kevin Kreiser Jan 17 '16 at 2:24

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.