0

I installed 14.04.3x64 LTS on hd1 with Win10 existing on hd0, using a live USB. No secure boot, no BIOS only UEFI options were selected from boot options firmware on HP desktop.

My intentions were to install Ubuntu make sure both OS would load then go back and set up rEFInd in the /boot/efi/EFI/refind directory of the new Ubuntu install, as I have on my laptop.

Ubuntu worked great, I updated played around with it then rebooted into Windows. Windoze worked and then ... Opps! When rebooting the Win boot menu gave me the option of Win and Ubuntu. On selecting Ubuntu it could not find Grub2 or the windows boot.

Went back to the live USB stick and installed the Boot Repair utility and posted the boot-info results at pastebin URL: http://Paste.Ubuntu.com/14524321/

The boot utility indicated that there was no MBR on sda or sdb. My understanding was the I would only require an efi partition and Ubuntu boot would have an EFI section.

I am confused on how to proceed. The utility says use diskpart and create MBR partition 150 - 250 MB and the utility tool would place Grub2 here then Ubuntu would boot.

I think if I can get Ubuntu to boot back up from sdb2 from the efi boot order I have set in my firmware menu I could set up rEFInd in Ubuntu boot as documented on the refind web documents. After doing this I would be able to choose the efi boot system it detected which should include Win 10.

The only access I have now to the drives are through the Try Ubuntu drive on /dev/sdc.

Thanks for any suggestions.

1

It looks like you've got an HP. Many HPs have known EFI bugs that prevent them from booting anything but Windows via the normal EFI boot order mechanism. This might be your problem; however....

There's no evidence of GRUB on your EFI System Partition (ESP; /dev/sda2 in your case). This might be an oversight of Boot Repair/Boot Info Script; it sometimes omits valid boot loader files. It could also be that the files have "disappeared" because of a filesystem error. This can happen because you haven't disabled the "Fast Startup" feature in Windows 8 and later. In Windows 8, you can do so as described here, among other places. In Windows 10, the instructions are here, among other places. (You may also need to disable hibernation, as described here.) Note that disabling Fast Startup won't fix any filesystem damage that already exists, so you may need to use Boot Repair or some other tool to re-install GRUB. Alternatively, since you want to use rEFInd in the long run, you can skip GRUB -- use rEFInd on a USB flash drive or CD-R (you can get images from its downloads page), boot Ubuntu using it, and install rEFInd.

  • Thank you Rod. So you would install rEFInd in /dev/sda2/boot/refind ? – ken.504 Jan 17 '16 at 15:10
  • Not quite. On your system, rEFInd's default location would be EFI/refind on /dev/sda2. Note that /dev/sda2 is a device file, not a mount point, so you'd never actually use /dev/sda2/EFI/refind as a reference. The refind-install script, which comes with rEFInd and is run automatically when you install the Debian package or PPA, handles this automatically. – Rod Smith Jan 17 '16 at 23:41
0

I solved this problem by using rEFInd and the documents provided by www.rodsbooks.com. After installing Ubuntu 14.04.3 from the live USB and running the program some I booted back to Windows 10. This worked untill booting back to Ubuntu, which gave me no boot menu to Windows or Ubuntu.

I was able to get both hard drives back with the respective OS by using the bootable CD of rEFInd. This gave me the boot menu of Windows and ubuntu.

After going in to the new install of Ubuntu on my second drive I ran the install procedure described for Ubuntu by www.rodsbook.com and the rEFInd documentation.

Now dual booting using the rEFInd menu with no issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.