2

I recently switched from openSuse (KDE) to ubuntu 15.10 (Gnome). I'd like to use a mobile broadband Huawei USB stick, that did work in openSuse. However, I am having trouble using it in ubuntu.

For some time, I was able to use it in ubuntu with a very silly procedure:

  1. Insert stick --> nothing seems to happen
  2. Although NetworkManager is running already, start a second instance with nm-applet.
  3. Remove stick, insert it again --> nothing seems to happen
  4. Interrupt the second instance of NetworkManager.
  5. Remove stick, insert it again --> NetworkManager shows a mobile broadband connection.
  6. Click on the connection; NetworkManager claims that it is now connected.
  7. Start Firefox and observe that there is in fact no internet connection.
  8. Remove stick, insert it again --> NetworkManager does not recognise the stick.
  9. Remove stick, wait a few seconds, insert it again --> NetworkManager recognises the stick, and can establish a connection.

Really silly. But it shows that in principle the stick works in ubuntu. Unfortunately, it is not working now. The difference is in step 6.: NetworkManager does show that the mobile broadband is available, but does not claim that there is a connection after clicking on it.

Further observations:

  • When I try to edit the mobile broadband connection, I get the error "settings/nm-settings-connection.c.955 - Connection didn't have requested setting 'ppp'.", regardless whether the stick is inserted or not.
  • There is no pin activated (at least I was never asked for a pin in openSuse or neither by my mobile phone, when I insert the USB stick's sim card into my phone). So, my question is (I think) not a duplicate of http://ubuntuforums.org/showthread.php?t=2306925
  • I see this:
$ lsusb
Bus 003 Device 002: ID 8087:8001 Intel Corp. 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 0930:0225 Toshiba Corp. 
Bus 001 Device 002: ID 04f2:b448 Chicony Electronics Co., Ltd 
Bus 001 Device 009: ID 12d1:1446 Huawei Technologies Co., Ltd. Broadband stick (modem on)
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

(How to insert code here?). Hence, it does recognise the stick as a modem. Surprisingly, sometimes it does not recognise the stick as a modem -- it just shows "broadband", but not "(modem on)". And this seems to be precisely the case when NetworkManager does show that a mobile broadband is available. Shouldn't it be the other way around?

  • I also tried sakis3g: I disabled networking in the NetworkManager (or even stopped it with "sudo service network-manager stop"), started sakis3g (which I equipped with a config file found in the internet), and tried to connect. But alas, the error after entering my sudo password is this:

    Cannot execute command ' '/home/king/software/sakis3g --interactive --nostorage --pppd APN="internet.eplus.de" APN_USER="eplus" APN_PASS="gprs" SGUI="zenity" USBINTERFACE="0" USBMODEM="12d1:1446" OTHER="USBMODEM" MODEM="OTHER" MENU="CONNECT" DISPLAY=":0" LOCALAUTHORITY="/home/king/.Xauthority"''.

Unfortunately it doesn't tell why it cannot execute the command.

So, what can I do to track the problem down and make the stick work again? Shall I try wvdial (which I have never used before, but found some hints in internet), or is there a way to make NetworkManager functional?

I have no WiFi at home. So, the only way to access internet at home currently is under Windows, which is useless for my work (in computer algebra).

EDIT:

Today, I used the mobile broadband stick in Windows (not for the first time, but the previous time was years ago). As a result, the behaviour of the stick in Ubuntu has changed, and I modify my questions as follows:

  • When lsusb does not show the stick is "(modem on)", then sakis3g can use the stick. That has not been the case before, sakis3g had errors. Follow-up question: Why has it not worked before, i.e., why is Windows needed to make the stick work in Ubuntu?
  • The connection is a lot slower in Ubuntu than in Windows, and also slower than with NetworkManager (the stick did work with NetworkManager for some very few times). Follow-up question: How to obtain a competitive speed by sakis3g or by other means?
  • NetworkManager is still unable to use the stick (but would still show a mobile broadband, if the stick is not "(modem on)"). Question: How to make the stick work with NetworkManager? I would prefer it over sakis3g.
  • It is still the case that sometimes the stick is in the "(modem on)" mode (which is bad for sakis3g), sometimes not (which is good). Question: How to obtain a usable mode reliably?
  • I am still unable to edit the mobile broadband connections in NetworkManager. Question: How to make it editable?

Best regards, Simon

closed as off-topic by WinEunuuchs2Unix, Pilot6, George Udosen, David Foerster, Eric Carvalho Jul 17 '17 at 12:13

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – WinEunuuchs2Unix, Pilot6, George Udosen, David Foerster, Eric Carvalho
If this question can be reworded to fit the rules in the help center, please edit the question.

  • NetworkManager error looks like bug #1508718 – bain Jan 17 '16 at 19:28
  • Stick behaviour might have changed because Windows software installed new firmware. – bain Jan 17 '16 at 19:29
  • @bain: How long does it typically take for such kind of bugs being fixed in ubuntu? – S. King Jan 22 '16 at 13:32
  • There is no typical time.. someone who experiences the bug needs to figure out a fix. Maybe it is already fixed upstream. According to the bug report This broke between 1.0.4-0ubuntu3 and 1.0.4-0ubuntu5 so it was probably an Ubuntu specific patch that broke it, and it probably wouldn't be that hard for a developer to figure out, just look at the patch differences between those two versions, and keep disabling changes until the bad one is apparent. – bain Jan 22 '16 at 13:53
  • Facing same issue, in my case initially it was working then suddenly it stop working, accidentally I remove network manager and install 1.0.4-0ubuntu5, after reboot it works but when I again reboot it it doesn't work. @bain Could you please tell me how I can apply patch for this? Actaully I am new to ubuntu and after googling didn't find any solution. – Mithlesh Kumar Feb 25 '16 at 1:43