-8

I turned on my computer expecting it to appear and function as it normally does, seeing as I did NOT approve any kind of updates, changes or revisions to any software installed on it since it's last use.

Lo and behold, I log in to the most janky looking desktop I've seen in ages, with no way to undo the operation that wasn't even supposed to be happening in the first place. Attached is a picture of the OLD launcher/desktop I used to have, and also the same one I'm trying to get back to.

Decent looking Ubuntu desktop:
decent looking ubuntu desktop

I can't decide which one is more annoying & is pushing me more back towards Windows, the fact that I NEVER approved such a blatant and major change to my computer, or the fact that it's so blipping ugly & dysfunctional to use.

I've tried looking for ways to restore it, but all the links I can find only instruct how to install a completely new desktop environment all together(KDE/Gnome/etc) -- which is NOT what I want.
Here is a picture of the repulsive desktop I'm being bombarded with now:

Hideous Ubuntu desktop:
hideous ubuntu

This is extremely frustrating and unnecessary, because instead of simply asking me would I like to upgrade my desktop theme, where I could answer yes or no, now I have to take time and productivity out of my day to deal with this mess.

PLEASE help me revert the appearance and functionality of my desktop to it's original state?

  • 4
    Seriously? Agjsbmhndvnsv LMAO, this isn't even Unity, you installed GNOME – Eduardo Cola Jan 16 '16 at 0:27
  • 3
    Can you please reword your question to not be so aggressive? You installed GNOME3 and logged in to it instead of Unity. You would have had to consciously do that. It doesn't just happen. – dobey Jan 16 '16 at 1:59
  • as you can scroll down and plainly see, the question has already been resolved by users before you. – phillymcv Jan 16 '16 at 2:03
  • 1
    It's your own fault, you installed and logged into a gnome desktop. – SuperSluether Jan 16 '16 at 4:12
5

It seems you've accidentally installed the GNOME desktop environment. While I personally like it much more than Unity, I can see why you might hate something if it forces its way onto your computer. To get back to Unity (what you had before), you need to switch back to it.

First, however, you need to make sure that lightdm (the login screen to go along with Unity) is selected as the default to use. To do this, open a terminal (ctrl + alt + T) and run the command, sudo dpkg-reconfigure lightdm. Put in your password (you won't see it being typed), and wait for a popup asking you to choose between two or more options. Use your arrow keys to go to lightdm and hit Enter to select it.

Now that you're done with that, reboot (a logout may be enough, but I'd rather play it safe). Now you should be at the login screen. Before you login, however, hit the gear icon near the password field (I believe it's to the right of your username) and choose the Ubuntu Desktop or Unity option. I'm not sure which one you'll see, but it should be one of those.

After you've selected Unity/Ubuntu Desktop, login and you should be back to normal.

  • thank you for not only instructing how to change it, but to make sure this issue doesnt arise again. Im not sure whos in charge of making user experience decisions in the ubuntu development group, but they should seriously reconsider their design decisions. Little things like this is what prevents a product from gaining a significant market share/user base. the product shouldnt be changing things the user doesnt know about, or hasnt explicitly and clearly disclosed. – phillymcv Jan 16 '16 at 0:37
  • 5
    @phillymcv this sort of thing doesn't happen automatically, and never has. We leave that to Apple. There's no way to prevent this issue from arising again, as it shouldn't have even happened. If you installed anything recently, that could be what installed GNOME. Someone could have also played a prank on you. This wasn't the fault of Canonical. The installation of separate DEs is completely invoked by either the user or a third-party script/program. – TheWanderer Jan 16 '16 at 0:39
  • 2
    @phillymcv It's also worth noting that a lot of people like it (I'm not one of them FWIW) so, even though we both hate it that it is just our personal choice which, believe it or not, many disagree with. I try to be respectful of that, hideous as I find it :) – Seth Jan 16 '16 at 2:37
0

It looks like you're running gnome. On the login screen select the DE icon and click Unity, if you don't get that option, do sudo apt-get install unity.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.