1

I installed Kubuntu a few days ago, and I have in a partition alongside windows (all UEFI).

Right now if I boot the computer the windows boot loader starts and Windows starts, so to start ubuntu I have to press Esc, then it lets me boot different things found in the hardrive, I have to select "ubuntu", then grub loads and let's me select again either ubuntu or windows. This is really anoying.

The output of efibootmgr in linux is this:

BootCurrent: 0004
Timeout: 5 seconds
BootOrder: 0002,3002,0004,2001,2002,2003
Boot0000* Disco duro del portátil
Boot0002* Windows Boot Manager
Boot0004* ubuntu
Boot2001* USB Drive (UEFI)
Boot2002* Internal CD/DVD ROM Drive (UEFI)
Boot3001* Internal Hard Disk or Solid State Disk
Boot3002* Internal Hard Disk or Solid State Disk
Boot3003* Internal Hard Disk or Solid State Disk

As expected. If I do a sudo efibootmgr -o ... then I can change the boot order to put 0004 in front. If I do so and run efibootmgr again then the order appears correctly changed. If I reboot the computer, however, the order is not respected, it just boots window again, and if I go back to linux and run efiboomgr, then the order changed back to the one shown above.

Why could this happen and how do I make the change persistent?

1
  • Have you tried using the UEFI setup program directly to change the order? Jan 15 '16 at 22:24
2

It's possible that this is a Secure Boot problem. Try disabling it from the BIOS UI.

1
  • This worked. I had to deactive "inherited compatibility" (not sure that's the right translation), and then deactivate secure boot. Thanks! Jan 16 '16 at 1:19
0

This looks like bug https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1286388 . For me it was a temporary situation, until the next kernel update. Add yourself to the bug with the "does this bug affect me" button near the title.


The assumption is that you do not have to boot to Windows to lose the order. Of course, Windows can and sometimes does mess with the order, but I cannot blame Windows if I don't boot it, and the order still changes. I cannot recall how many times I booted and this happened, but until I ran an Ubuntu update, it persisted. Perhaps Windows was setting the "next boot" and I kept getting snagged, but then why did an update fix things?

2
  • I do not think that is a Linux bug, but really is a Windows feature. :) Windows often resync BCD with UEFI. And many vendors modify UEFI to use description as part of boot. UEFI says not to use description, but vendors still do it. And only description that works is Windows. Often then better to set default to fallback or hard drive entry using /EFI/Boot/bootx64.efi that really is a copy of shimx64.efi.
    – oldfred
    Jan 16 '16 at 0:20
  • It can't be that because I change the order in linux, reboot, and windows boots, if windows was changing the order then it should boot into grub after shutting down from linux Jan 16 '16 at 1:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.